#35 build crash

open
nobody
Linux (12)
5
2007-11-25
2007-11-25
No

/usr/bin/mcs -pkg:gtk-sharp-2.0 -pkg:glade-sharp-2.0 -reference:Mono.Posix -resource:./../resources/openvpn-admin.glade,openvpn-admin.glade -resource:./../resources/openvpn-admin.png,openvpn-admin.png -resource:./../resources/certificate.png,certificate.png -resource:./../resources/posix/gtk-connected.png,gtk-connected.png -resource:./../resources/posix/gtk-disconnected.png,gtk-disconnected.png -t:winexe -out:openvpn-admin.exe ./MainWindow.cs ./BaseDialog.cs ./BaseForm.cs ./CertForm.cs ./Certificate.cs ./CertificationInfo.cs ./ChangeForm.cs ./Configuration.cs ./DetailForm.cs ./KeysForm.cs ./LogForm.cs ./PassForm.cs ./extras/AboutDialog.cs ./extras/BaseMainWindow.cs ./extras/TrayIcon.cs AssemblyInfo.cs Defines.cs
./MainWindow.cs(65,25): warning CS0436: The type `Gtk.AboutDialog' conflicts with the imported type `Gtk.AboutDialog'. Ignoring the imported type definition
/usr/lib/mono/gac/gtk-sharp/2.10.0.0__35e10195dab3c99f/gtk-sharp.dll (Location of the symbol related to previous warning)
./extras/AboutDialog.cs(31,22): (Location of the symbol related to previous warning)
./MainWindow.cs(503,84): error CS0122: `Gtk.Widget.ActivateDelegate' is inaccessible due to its protection level
/usr/lib/mono/gac/gtk-sharp/2.10.0.0__35e10195dab3c99f/gtk-sharp.dll (Location of the symbol related to previous error)
Compilation failed: 1 error(s), 1 warnings
make[1]: *** [openvpn-admin.exe] Error 1

Discussion

  • Logged In: NO

    I have exactly the same problem.
    OS : Ubuntu 7.10 (64 bits)

     
  • I also have the same problem, with slightly different version numbers in it ...

    ./MainWindow.cs(503,84): error CS0122: `Gtk.Widget.ActivateDelegate' is inaccessible due to its protection level
    /usr/lib/mono/gac/gtk-sharp/2.12.0.0__35e10195dab3c99f/gtk-sharp.dll (Location of the symbol related to previous error)
    Compilation failed: 1 error(s), 1 warnings
    make[1]: *** [openvpn-admin.exe] Error 1

    Running ubuntu 8.04 server

     
  • same problem here

    os: gentoo 2.6.27 64bit
    openvpn-admin 1.9.4

    has anybody found a solution yet?

     
  • Hi, i have the same problem...

    i try compiling with various mono, gtk-sharp versions, but without success.

    It happend after global system update.

    I think there is a problem with some dependend library and it's version.

    Binary packages don't work for me too.

     
  • Hi, i solved the problem.
    After downgrade of gtk-sharp and glade-sharp to version 2.8.2 openvpn-admin works correctly.

    previously i try only 2.12* builds, whitch doesn't works.
    Maybe 2.10.* may work too, but i not tested that.

    Good luck

     
  • TRB
    TRB
    2010-04-02

    Just need to modify the make file so that the compiler used is not 'mcs' but 'gmcs'. This fixed this build error for me.