Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Memory leak fixed

It appears that there was a fairly significant memory leak in the Crypt_CBC.php module.

I've made the changes, and released the latest version of the class through the regular PEAR channels.

If you have PEAR installed and configured properly, then a simple:

pear upgrade Crypt_CBC

will work. But it probably won't, because PEAR's upgrade feature isn't working too well right now, so grab the file from the website:

http://pear.php.net/get/Crypt_CBC

and unpack it where appropriate.

NOTE: this fix really requires libmcrypt >= 2.4.16, but I would highly recommend the latest stable version (right now, it's 2.5.0).

- Colin

Posted by Colin Viebrock 2002-05-09