#9 Cannot run V 0.9.3 on Mac OS - Java version check

Bug
closed-invalid
nobody
Other (11)
5
2009-10-29
2009-10-29
Anonymous
No

Open Rocket 0.9.3 will not launch on Macintosh OS 10.5 (I have 10.5.1) as the Apple-supplied Java version doesn't match what Open Rocket expects. The error message reads as follows: "Java SE version 6 is required to run OpenRocket. You are currently running Java HotSpot(TM) Client VM version 1.5.0_13-b05-237 by Apple Inc."

Here are the messages direct from the system log:
"[0x0-0x792b924].com.apple.JarLauncher[66464]: Error starting OpenRocket:
Oct 28 23:08:36 BernardCawleysPowerBook [0x0-0x792b924].com.apple.JarLauncher[66464]: Java SE version 6 is required to run OpenRocket.
Oct 28 23:08:36 BernardCawleysPowerBook [0x0-0x792b924].com.apple.JarLauncher[66464]: You are currently running Java HotSpot(TM) Client VM version 1.5.0_13-b05-237 by Apple Inc."

Sun's site says this about Java on Macs: "Apple Computer supplies their own version of Java. Use the Software Update feature (available on the Apple menu) to check that you have the most up-to-date version of Java for your Mac."

I have the latest version for my version of Mac OS.

Discussion

  • Sampo Niskanen
    Sampo Niskanen
    2009-10-29

    This is a known issue for Mac OS X, because it ships by default with Java 5 instead of Java 6. The only way to get OpenRocket running is to install a newer Java version. See the thread at https://sourceforge.net/apps/phpbb/openrocket/viewtopic.php?f=3&t=6 for more information about the issue.

     
  • Sampo Niskanen
    Sampo Niskanen
    2009-10-29

    • status: open --> closed-invalid