Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#231 KVM plugin broken

open-accepted
Matt
General (15)
5
2012-12-13
2012-12-07
Vinz
No

Hi, I'm testing OpenQRM, fresh install, svn 2325 currently, and the KVM plugin is severly broken. I have created a VM with the KVM plugin, it failed after a while telling me the plugin for that returned an error (remote physical host), but now the VM appears in resources. Trying to delete it tells me to use the KVM panel, but this panel tells me I have no VM => I cannot remove my ghost resource. What I'm supposed to do?

Discussion

  • Matt
    Matt
    2012-12-10

    Hi Vinz,

    thank you for the bug report. Since 5.0 we have mapped VMs and their resources.
    In your situation it would be useful to get to know the real reason why the VM could not be created !?

    Anyway the recommendation is to login to the openQRM db and remove the "ghost" resource in the resouce_info table. Please also make sure ot remve the resource entry in the /usr/share/openqrm/plugins/dhcpd/etc/dhcpd.conf and to restart the dhcpd plugin afterwards.

    Closing this bug for now. Please re-open with more details if you still have troubles with that.

    Many thanks and have a great day,

    Matt Rechenburg
    Project Manager openQRM

     
  • Matt
    Matt
    2012-12-10

    • status: open --> closed-works-for-me
     
  • Matt
    Matt
    2012-12-13

    • status: closed-works-for-me --> open-accepted
     
  • Matt
    Matt
    2012-12-13

    Hi again Vinz,

    our QA found that the VM name check does not work as expected so re-creating a VM with an already existing name will cause this trouble.
    -> Was this the same situation in your case ?

    Re-opening this ticket. We are working on fixing it.

    Matt Rechenburg
    Project Manager openQRM