Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Time Format

Help
louapnic
2007-09-24
2013-05-15
1 2 > >> (Page 1 of 2)
  • louapnic
    louapnic
    2007-09-24

    I am in Australia. Can I modify the date to format local rather than the US format?

     
    • Howard Katz
      Howard Katz
      2007-09-24

      OpenProj will use your system's regional settings for formatting dates and times.  Try setting it there.

       
      • reyjinn
        reyjinn
        2007-10-30

        Hi, I'm having the same problem with the US time format (at least in the start date & finish date columns) and OpenProj is not picking up my regional settings.  I'm running OpenProj on Kubuntu 7.10.  Does it only detect regional setting in MS?
        Regards,
        reyjinn

         
    • Goh Bee Hock
      Goh Bee Hock
      2007-10-31

      I am from Singapore and my regional settings is not picked up and openproj is showing in US date format.

       
    • R N Cramer
      R N Cramer
      2007-12-17

      I have the same problem here in the UK. UI have a further problem in that I can't select the dates I want from the calendar. I want to select 5th Jan to 11 Jan as a holiday, but it always goes to 14th Jan !!

      This is currently making this software (which is really easy to get going with) unusable for my project management. A real shame.

       
    • mowerte
      mowerte
      2008-01-08

      Hi, I'm in South Africa and have the same problem with showing the correct regional time format.

       
    • Sam Sandqvist
      Sam Sandqvist
      2008-01-22

      You can easily change the language and formats.

      Windows: edit openproj.bat

      add the following to the java command line

      -Duser.language=en -Duser.region=GB

      for UK format. Use any legal combination, e.g., fr and CA for French in Canada, or en and AU for Australian English. This will change both your language and locale formats (dates and times).

      On Unixy systems, change openproj.sh in the same way.

       
    • Kevin Crowley
      Kevin Crowley
      2008-06-25

      Just a note for any Mac OSX users. If you want regional settings to take effect then the way I achieved it was:

      1) open a terminal
      2) cd /Applications/OpenProj.app/Contents
      3) vi Info.plist
      4) find the line that says:

      <string>-Xms128m -Xmx768m</string>

      and change it to read:

      <string>-Xms128m -Xmx768m -Duser.language=en -Duser.region=AU</string>

      Read the thread above for other region codes.

      Hope this helps someone...

       
    • beechwood1
      beechwood1
      2009-04-05

      for Kevin Crowley
      Using MacOSX 10.5.6
      This does not contain the line
      <string>-Xms128m -Xms768m</string>
      nor anything like it

      Can you suggest alternative one to obtain d/m/y format dates?
      (or even y/m/d format, as in Europe)
      tia

       
      • Sam Sandqvist
        Sam Sandqvist
        2009-04-05

        To modify the time format, add the region with

        -Duser.region=GB

        or similar to affect the time, date, and currency.

         
    • beechwood1
      beechwood1
      2009-04-09

      Thanks Sam, but where exactly should it be entered? On its own line? Or on a new line?
      Note, when I follow Kevin's advice, I do not get the line that he quotes
      tia

       
      • Sam Sandqvist
        Sam Sandqvist
        2009-04-09

        On the Mac, navigate to Applications, and right-click on the OpenProj icon.

        Choose Show Package Contents, and a new window with the content will open.

        Click Contents, and the info.plist and the Property List Editor will open.

        Click the arrow at Root, and last in the list, again on the Java arrow.

        The last option is VMOptions, where I have

        -Xms128m -Xmx768m -Duser.region=GB

        (i.e., entered the region at the end of the string).

        Close everything and restart OpenProj.

        Cheers,
        Sam

         
    • beechwood1
      beechwood1
      2009-04-12

      Thanks Sam, but no result. Maybe I'm just dumb.
      (Third para above)
      I clicked Contents, and it opened to show -CodeSignature folder;  CodeResources alias; Info.plist; MacOS folder; PkgInfo; and Resources folder.
      No sign of Property List Editor anywhere; Info.plist opened with TextEdit
      Did not see/have an arrow to click at Root, nor the Java arrow.
      Went to -xms128m - Xmx768m, and added the
      -Duser.region-NZ phrase.
      No result, so substituted  -Duser.region-GB phrase. Still no result.
      Left the plist like that and gave up.

       
      • Sam Sandqvist
        Sam Sandqvist
        2009-04-12

        Hmmm...

        I'm on 10.4, not 10.5 Leopard - maybe the behaviour has changed a bit.

        However, basically I believe you did everything correctly until (if your post is accurate!) the very last step:

        -- you say: -Duser.region-NZ
        --should be: -Duser.region=NZ

        (i.e., equals sign, not hyphen).

        Also, try checking if a right click on the info.plist and Open with reveals the elusive Property List Editor... but I faintly recall that editing with TextEdit is fine as well.

        I opened mine with TextEdit the line in question is

        <string>-Xms128m -Xmx768m -Duser.region=GB</string>

        Cheers,
        Sam

         
    • beechwood1
      beechwood1
      2009-04-12

      -- you say: -Duser.region-NZ
      --should be: -Duser.region=NZ

      (i.e., equals sign, not hyphen).

      Voila!!

      Many thanks

      Cheers

      Geoff

       
  • nick
    nick
    2009-10-22

    Hi,

    I'm in France and I want the language to be English and the date format to be European.  I add -Duser.language=en and the language changes fine but the date format stays US.  If I add -Duser.region=GB, the date format changes but the language stays French.  How do I have both GB region, (for date format) and en language (for English menus etc.)  If I add both arguments, only the first is respected.

    Thanks

     
  • Daniel Perez
    Daniel Perez
    2010-11-23

    I edited from terminal with vim editor, and the date format is working using GB (dd/mm/yyyy)
    I tried for Spain date format with ES and SP with negative results.

     
  • FX Cormontagne
    FX Cormontagne
    2011-02-22

    It seems that you cannot mix any region with any language. If you want the interface to be in English, I suggest you try on english speaking regions. I am working in an international organisation in Belgium. lang=en region=be did not produce what I wanted: date format d/m/y and currency EUR.

    I tried lang=en region=IE (ireland) and … tadaaa! works just fine: date are in european format, currency in EURO and UI in english.

     
  • Tony Pappas
    Tony Pappas
    2011-06-30

    Is it possible to set the date format to ISO standard of "yyyy-mm-dd"? Thanks

     
  • Paulo Braga
    Paulo Braga
    2011-07-04

    Adding -Duser.language=en -Duser.region=ZA will result in English and yyyy/mm/dd.
    Seems that there's no way to have yyyy-mm-dd: all combinations of "en" plus country codes that use "yyyy-mm-dd" did not work.
    It would be nice if date and time configuration could be made independently from within the program (because Unix is less flexible than Windows in this respect).

     
  • Paulo Braga
    Paulo Braga
    2011-07-04

    Note that even though it's possible to have dates as yyyy/mm/dd, how to get rid of that ugly am/pm and have a sane 24 h format instead?

     
  • Edwood
    Edwood
    2011-11-10

    I had a bit of a nightmare getting this to work, but thanks to this thread, and some persistence, I can now switch over to Open Project… Stoked!

    Notes for windows users:
    - It seems to me that If any of the parameters in the batch file are erroneous, they are ignored. (eg. language=NZ)

    Associating your Open Project Files
    The batch file parameters are only used when you actually run the batch file (obvious I guess) . 
    Your .pod files are associated with the .exe, and therefore, if you open your project file by double clicking on it, you will have the wrong date format.
    You can't just associate the .pod files with the batch file because it doesn't really accept input parameters.
    For now, i'm stuck having to:
      - 1) Open Open Project using the batch file
      - 2) Click 'Open Project", and then browse to my project file

    I am sure that one of the smart cookies out there can give us a nice easy way to modify the batch file so it accepts an input paramater.  (ie. then you can associate .pod files with the batch file)

    So… smart cookies?
    batch file is

     
  • lordy
    lordy
    2012-01-11

    To edit the JVM settings on Windows associated with the exe (not the bat file).
    Edit the ini file  (eg \Program Files\Serena Software Inc\OpenProj\OpenProj1.4.0.ini)

    [Java Runtime Environment]
    Maximum Version=any
    JVM Type=favor_client
    Minimum Version=1.5
    Main Class=com.projity.main.Main
    [b]Virtual Machine Parameters=-Duser.language=en -Duser.region=GB [/b]
    [Product Information]
    ..
    
     
  • lordy
    lordy
    2012-01-11

    I worked that out by Googling 'JVM Type=favor_client' , this lead me to the installer being used, and then how to add JVM properties.

     
  • Paulo Braga
    Paulo Braga
    2012-01-13

    Edited OpenProj1.4.0.ini as suggested but, unfortunately, it did not work.
    Inserting the language and region parameters in the batch files works, though.

     
1 2 > >> (Page 1 of 2)