Installing ObexFTP

Help
2007-04-18
2013-05-01
  • I'm running Ubuntu Dapper, and I'm trying to install Openobex and Obexftp to use with my Siemens S45 (data cable).

    I've installed Openobex 1.3 (thanks to a post here!) but when I try to install ObexFTP I get:

    checking for pkg-config... /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0... yes
    checking for OPENOBEX... configure: error: Package requirements (openobex) were not met:

    No package 'openobex' found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables OPENOBEX_CFLAGS
    and OPENOBEX_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.

    I've only been using Ubuntu since December, and I've only installed stuff using Synaptic up until now. I've looked at the pkg-config manual, but I'm not sure what I should be doing. Both Openobex and ObexFTP are in my home directory, in the folders they extracted to (default folders).

    TIA

     
    • There will most likely be a problem if you install OpenOBEX with a different prefix than pkgconfig.
      (distro packages use /usr usually, and /usr/local is the default if you install a package manually)

      Try copying /usr/local/lib/pkgconfig/openobex.pc to /usr/lib/pkgconfig/openobex.pc

       
      • All that's in /usr/local/lib/pkgconfig/ is python 2.3, python 2.4, and site_ruby - so I obviously haven't installed OpenObex correctly. :(