#56 ObexFTP ./configure bug

closed-works-for-me
nobody
None
5
2008-05-10
2008-03-04
Martin Lipocky
No

The configure script does not check SWIG presence. Therefore, an error may occur during the compilation.

(Using PCLinuxOS 2007)

Discussion

    • status: open --> closed-works-for-me
     
  • Logged In: YES
    user_id=136432
    Originator: NO

    SWIG is not needed. Only maintainers should enable SWIG. Can you give details how this bug shows and which version you used?

     
  • Martin Lipocky
    Martin Lipocky
    2008-05-11

    Logged In: YES
    user_id=1448458
    Originator: YES

    I was compiling obexftp-0.20. I suspect that the default configure switch was --enable-swig. I admit that the swig is not needed, but the compilation was successfully completed just when I had installed swig on my system.

    But now in order to respond you I tried to trigger the compilation error again, but unsuccessfully, even when I had uninstalled swig and no matter I used GCC3 or GCC4. I also switched --enable-swig and the compilation went through successfully also without swig on my system. Could you please check what is the default: --enable-swig or --disable-swig?

     
  • Logged In: YES
    user_id=136432
    Originator: NO

    Thanks for reporting back on this. The default is to disable swig.
    (See also "./configure --help" it should say "--enable-swig Rebuild language bindings [default=no]")
    Please try the latest obexftp-0.22-rc9 from http://triq.net/obexftp/