#71 Latest version crashes on Windows and fails on Linux

v1.0_(example)
open
nobody
None
1
2014-02-23
2013-11-28
Gareth
No

When using the latest version of OpenNX to connect to a 3.5 version of FreeNX Server the program crashes in Windows 7 with no error messages.

In Linux Debian 6 an OpenNX error is thrown "Unexpected termination of nxssh".

When I download the previsous version of OpenNX everything works perfectly.

Discussion

  • I can confirm this bug for me in Windows 7 trying to connect to a 3.5 server.

    If I install OpenNX-0.16.0.725 then it works fine.

     
  • Liam Gretton
    Liam Gretton
    2013-12-11

    Confirmed here too. I've tried with a number of Windows 7 clients and 729 fails to make a connection to our FreeNX servers every time. Nomachine's NX client and normal SSH have no problems.

    It crashes on clicking the 'Login' button. No connection is made to the server as far as I can tell, definitely no attempt to authenticate at least. Crash report is as follows:

    Problem Event Name: BEX
    Application Name: opennx.exe
    Application Version: 0.16.0.729
    Application Timestamp: 5293924f
    Fault Module Name: StackHash_0a9e
    Fault Module Version: 0.0.0.0
    Fault Module Timestamp: 00000000
    Exception Offset: 0028d140
    Exception Code: c0000005
    Exception Data: 00000008
    OS Version: 6.1.7601.2.1.0.256.4
    Locale ID: 2057
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

     
  • Christopher
    Christopher
    2013-12-20

    Confirmed for me too. Windows 7 64bit. 729 failes to make a connection - same experience as Liam

     
  • BioCyberman
    BioCyberman
    2014-01-07

    With the same server (FreeNX on Ubuntu Precise), I could not connect with latest version of OpenNX from Windows 7 and XP.

     
    • sjz
      sjz
      2014-02-28

      It's a shame that this report is mixing Windows and Linux reports, because the issues are probably not related.

      For Ubuntu and Mint Linux (and possibly other Debian derivatives), try adding a symlink:

       sudo ln -s /usr/lib/opennx/lib /usr/lib/opennx/lib64
      

      Seems to be a missing step in the pre-packaged install-script.

      Windows: Version 725 works for me. Comparing the files installed by 725 and 729, it looks to me as if 729 and some other versions are missing the components that comprise the XminG X server. (This problem might be hidden when upgrading from an earlier version where those components were included and so would already exist on your system).

       
      Last edit: sjz 2014-02-28
  • I can confirm this on Windows 7, both 32-bit and 64-bit, and Windows 8. I did not notice the problem on Windows XP, but I might have been running the older version there. I will check when time permits.

     
  • TGP1994
    TGP1994
    2014-02-23

    I'd like to add to this as well, I am experiencing the error too. I'm attempting to log in with NX's private key. I also want to add that, like Chris, downgrading to version 725 has everything working fine again.

     
    Last edit: TGP1994 2014-02-23