MySQL Connector/J needs to be upgraded

Idler Fang
2005-08-12
2013-04-23
  • Idler Fang
    Idler Fang
    2005-08-12

    For some new version of MySQL (in my case 4.1.13a), the connector in OpenIPMP distribution package may cause a handshake failure. Old connectors (mysql-connector-java-2.x.x-bin.jar) should be upgrade to version 3.1.10.

     
    • Craig Miller
      Craig Miller
      2005-08-12

      Yes; that's definitely true. What version of OpenIPMP are you using. I thought we fixed that problem with the 0.8.1 patch ... ?

       
      • Idler Fang
        Idler Fang
        2005-08-12

        I think I have version 0.8.1. The file name is openipmp_v081.tar.gz.

         
    • chris mollis
      chris mollis
      2005-08-13

      if you use any version of MySQL past 4.024 (I believe), you'll get handshake errors.. (we fixed a grant script problem, but didn't upload any new drivers).. BTW:  the new mysql jdbc drivers are backward compatible with the 4.0x versions of mysql..

       
    • Kimmy
      Kimmy
      2005-08-26

      I encountered the same problem. Your doc "OpenIPMP Installation Guide (Server)" said that you have tested it on the 4.1.x stable release of MySQL, but I think you didn't fix this problem in you new version. I think problem happened When deploying the JBOSS. If I upgrade the connector, I will have to change the installOsms.bat and upgrade the jdbc driver, right? I think I'd better to use the 4.0 version of mysql.