NationNotes - cannot share Custom Buttons

Help
Alex Volin
2014-02-10
2014-02-11
  • Alex Volin
    Alex Volin
    2014-02-10

    I’ve built an LBV form with the NationNotes fields in it. I did it as admin and tried to share the form with our users. From a user account I could get categories using the ‘Personalize’ function but the custom buttons I created did not show up. I noticed that the ‘template_users’ table did not get the appropriate rows referencing ‘cl_list’ items for the CustomButtons (list_type=6) for all users except for the user-creator (my uid) while for the other ‘list_types’ everything was in place. Is it a bug? Should I manually insert those rows to the table as a workaround or I just missed some functionality in ‘Personalize’?

     
  • Pieter W
    Pieter W
    2014-02-10

    Can you show a screen shot WITH and WITHOUT what you see and what you made? Did you follow the steps of the WIKI-pages?

     
  • fsgl
    fsgl
    2014-02-10

    Just imported an Eye NationNote into this Demo. Components will load via Personalize.

    The 11 Custom Buttons are in the customlists table. Adding them to template_users made no difference.

    No obvious way to share Custom Buttons. Does not seem to be a bug, however.

    Relevant quote from Harley Tuck's third article: "Templates (Components) can only be shared from "Available Categories" to the user who is logged in, not from the logged in user to another user".

    ZH Healthcare developed NationNotes. They will have to weigh in because the Wiki articles are silent on Custom Button sharing.

     
  • Alex Volin
    Alex Volin
    2014-02-11

    The first screenshot is WITH the Custom Buttons I've added (as admin). The 2nd one shows the same NationNotes but from a non-admin user account after personalization. This one is WITHOUT the buttons except the one (pointed by a red arrow) that I could add by inserting a row directly in the ‘template_users’ table (see the 3rd screenshot).

     
    Last edit: Alex Volin 2014-02-11
  • Alex Volin
    Alex Volin
    2014-02-11

    fsgl, I don’t now why it did not work for you. I am going to share all custom buttons with all users by creating an SQL INSERT statement and executing it for every uid. That’s just a workaround. It’s likely that some code is missing in share_template.php or personalize.php. I am not sure about it. It’d be good to hear from the code developers.

     
    Last edit: Alex Volin 2014-02-11
  • fsgl
    fsgl
    2014-02-11

    The Eye form was created in 4.1.1 and imported into the 4.1.2 (3) Demo. The old 4.1.2 Demo, built with Mandriva, had no import function whatsoever. The versions of PHP are different for all three. A conjecture would be that this disparity accounts for some of the problem.

    I used a similar Insert statement as in your third screenshot, but no dice.

    When my production copy was upgraded to 4.1.2, the Components had to be "shared" even though I was logged in as the Administrator and the Buttons were gone.

    ZH Healthcare is busily posting on the Zend Module thread. Perhaps one of them will notice this thread. If not, you devised on your own a solution (kudos) and got me thinking about how to nudge the Eye Custom Buttons to appear in another copy of OpenEMR.

     
  • Jack Cahn MD
    Jack Cahn MD
    2014-02-11

    Another problem (may need new thread) is that on my sandbox I enter a note with LBF-NationNotes and then go under reports. I can print with "Generate report" giving a complete note, but if I choose "Download pdf" I see only the LBF title and no text. Ubuntu 12.04, firefox, Okular for pdf.

    The CCD doesn't acknowledge the note at all.

     
  • fsgl
    fsgl
    2014-02-11

    It's a bug. More moola for the designated vendor.