why is this forum 1000% Anti-java?

Help
urusei
2006-02-14
2013-05-28
  • urusei
    urusei
    2006-02-14

    there are a lot of threads about the Java Api and how Java programmers seem to be having trouble linking it to Cyc - why does no one answer these queries?  Is it becuase no one knows?  Is it becuase you all don't like JAva or NooBs?

    I can't get the Java API to interface with Cyc either and I'm beginning to lose my patience with Open Cyc. 

    Don't the makers want Java developers to work with their product?  How can you encourage open source developement if you don't answer fundamental questions? 

    There are loads and loads of threads about people having problems getting their Java API to work with Cyc.  Come on, someone at least answer one of them.

    This is the deal

    I run the API demo, while I have Cyc on the go, and nothing happens.  The program compiles fine, it even runs but it doesn't do anything.  All I get is a black command prompt with the words 'connecting to open cyc' - that's it nothing else happens.

    If someone starts a thread complaining that they can't get it to work with some C program, everyone seems to be really helpful but the Java questions are allways ignored

    Looking through the forum I can find at least 10 threads related to OpenCyc and the fact that it seems doesn't seem to work too well with Java Api

     
  • alestarrr
    alestarrr
    2010-05-17

    Hi , and excuse for the informal interruption
    I´m student from ISPEJAE Institute,CUBA and  i working in a desktop aplications, that use OpenCyc v2.0querys like:
    isa _asertions(for instance and example relation between term  )
    _genls
    asertions(for class-subclas herarchy dependence )

    I  did  use the default constructor to create an instance of CycAccess
    CycAccess access = new CycAccess();
    ,but previusly click the C:\opencyc-2.0\scripts\run-cyc.bat ´s srcrip to start cyc server. It shows the following in a comand prompt:
    Start time: Sun May 16 09:42:58 CEST 2010
    Lisp implementation: Cycorp Java SubL Runtime Environment
    JVM: Sun Microsystems Inc. Java HotSpot(TM) Client VM 1.6.0 (1.6.0-b105)
    Current KB: 5018
    Patch Level: 10.128401
    Running on: FRANCOIS1
    OS: Windows Vista 6.0 (x86)
    Working directory: C:\opencyc-2.0\server\cyc\run
    Total memory allocated to VM: 1169MB.
    Memory currently used: 541MB.
    Memory currently available: 627MB.
    Initializing HL backing store caches from units/5018/.
    ;;  At this point the cyc http server is running and you can access
    ;;  Cyc directly via the local web browser.
    ;;  http://localhost:3602/cgi-bin/cyccgi/cg?cb-start
    ;;  You can browse cyc via the Guest account or perform updates by
    ;;  logging on as CycAdminstrator.
    CYC(1):

    and the aplications works!!!!!!!!!!,but only as a batch process, a  thread( an aplications working with directories, no user interfase). The problems comes when i try to use a java frame,with buttoms for user interfase interaction.
    It seem that is impossible to use AWT. Anyway i´m working in Eclipse Release 3.2.0 and JRE 5.0
    My stack trace comes as :
    org.opencyc.api.CycApiException: Invalid attempt to synchronously communicate with Cyc from the AWT event thread.

    org.opencyc.api.DefaultSubLWorkerSynch:
    Id: null
    Server: host localhost, cfaslPort 3614
    Status: Working
    Incremental results: false
    Timeout: 0 msecs
    Command:
    (CYC-IMAGE-ID)

    Please sorry for the unplacent bothering,but could you please help me or know someone-were that could……..  8]