iMAT and createTissueSpecificModel

Anonymous
2012-02-08
2013-05-30

  • Anonymous
    2012-02-08

    Hi,

    when I use the iMAT option to create a specific model with createTissueSpecificModel, the models I receive are not cropped down, but are the same size, as before.

    I tried this as well with the test-dataset provided with the COBRA installment, but also receive a model of the same size as the input model (here recon1).

    This phenomena does not occur with the GIMME option, but I would be glad if I could use iMAT, as I don't want to be relying on an objective function (which is required by GIMME).

    I am using COBRA 2.0.3 with Gurobi v4.61and gurobi mex v1.61 on 64 bit Linux.

    Any ideas?

     
  • Aarash Bordbar
    Aarash Bordbar
    2012-02-10

    Dear Sascha,

    We have come across this problem before. The problem has to do with the model used for the test, not the algorithm or expression data. I can send you a working Recon1 for iMAT if you like if you email me directly at aabordba_AT_ucsd_edu. This should fix the problem.

    Thanks
    Aarash