Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

importing spreadsheets

Abel Pol
2008-04-13
2013-04-24
  • Abel Pol
    Abel Pol
    2008-04-13

    Does anyone know if it's possible to convert two-column spreadsheets to an Impress slideshow? I love OpenCards, and think the concept is great. However, a lot of data like vocabulary lists resides in spreadsheets or .csv files. It would be ideal if there was a way of importing a spreadsheet into Impress so that Column A would be all the titles, and Column B the body itself. This would allow people to use programs like Logos to generate vocabulary lists for selected readings, and then import those into OpenCards to use as flashcards. I spent a few hours last night looking for some sort of (third-party) way of converting .xls or calc files into Impress or PowerPoint slides, but no luck so far. I have also tried Impressmenu->OpenCards->Advanced->'Import Flashcards', but that just opens Calc. If anyone knows of a program/hidden function/magic spell, I'd be obliged.

     
    • Holger Brandl
      Holger Brandl
      2008-04-13

      Hi Abel,

      CSV-import is a feature of OpenCards so I'm confident that we can find a solution for your problem.

      > I have also tried Impressmenu->OpenCards->Advanced->'Import Flashcards', but that just opens Calc
      Calc??? That would be cool kind of bug *bg*. I've looked around in the code but I can't see any reason why Calc should appear. You should see a dialog where a import-csv-file can be selected.

      Did Calc pop up immediately when you click 'Import Flashcards' or after you've selected a file in the import file-dialog. If the latter is the case: Could you attach you csv-file to this thread (as long as it does not contain any private data)? I would like enjoy Calc as well (but I will probably remove this 'feature' afterwards).

      Thx,
      Holger

       
    • Abel Pol
      Abel Pol
      2008-04-13

      Hi there,

      It turns out Calc was evoked because of a resource association. Right now, whenever I try importing my .csv file, nothing happens at all. The file is quite large; it contains about 800 biblical Hebrew vocabulary words. The data is separated by spaces, and the encoding is in Unicode UTF-8. I'm not sure how to attach a file to this thread, so I've posted some sample lines from the file below so that you can see them:

      "טוֹב"    "good"
      "שָׁמַיִם"    "heaven (pl)"
      "כֶּסֶף"    "silver"
      "חָכָם"    "wise"
      "זָהָב"    "gold"
      "מֶלֶךְ"    "king"
      "חֶרֶב"    "sword"
      "עַם
      sf  עַמִּי
      pl  עַמִּים
      definite: הָעָם"    "people"
      "אֶרֶץ

      definite: הָאָרֶץ"    "earth, land (f)"
      "יֶלֶד"    "boy"
      "אֱלֹהִים"    "God"
      "הֵיכָל"    "palace, temple"
      "רָעָב"    "famine"
      "בָּרָא"    "to create"

       
    • Abel Pol
      Abel Pol
      2008-04-13

      Hi Holger,

      Thanks for the tip, I got it running! I did download Notepad++, but as it turns out, I didn't need it. When you save a spreadsheet as a .csv file in Calc, you have the option of saving both as a "Unicode" file and as a "Unicode (UTF-8)" file. I didn't know this before, but if you save it just as a "Unicode" file it defaults to UTF-16.

      One problem that I did notice has to do with having multiple Hebrew words (e.g. singular, plural, etc.) in one cell. When it gets imported OpenCards thinks every line is a separate entry. So the entries that have multiple words with one English equivalent all get treated as separate cards, even though they were part of the same entry in the spreadsheet. Some of the Hebrew words show, and others don't. This seems to be the case even if I run a search-and-replace in Notepad first to try and get those entries on one line. Of course I don't have that problem with the entries that contain only one Hebrew-English word pair. Any ideas for a workaround would be greatly appreciated.

      Thanks for your time!

      Abel

       
      • Holger Brandl
        Holger Brandl
        2008-04-14

        Hi Abel,

        > OpenCards thinks every line is a separate entry.
        Yep, that's the idea of an CSV-import filter. :-) If a line contains more/less than one single 'tab' OC will skip this line.

        > This seems to be the case even if I run a search-and-replace in Notepad first to try and get those entries on one line.
        If you replace out all tabs in a line but the first, OC should import all the wordforms.

        Workaround:
        1) To overcome your problem do the following: ensure 1 tab per line and use a a special character (e.g. '+' or '@' or whatever) to indicate positions were you would like to have a line-break in the slides later on. You can even write a bashscript to transform existing files into such a format.
        2) Import it. Anything should appear although the lines will be long and without any line-break
        3) Use search and replace dialog (with 'More options'->'regular expressions') enabled to replace your special sign with a line break.

        -holger

        ps. unfortunately point (3) will be hard to realize because of issue http://www.openoffice.org/issues/show_bug.cgi?id=88283 . But the direction for a possible solution is hopefully clear. :-)

         
    • Abel Pol
      Abel Pol
      2008-04-16

      Success! For now the words are separated by slashes; once OpenOffice fixes the bug, I'll be able to use a regular expression to get them all on separate lines again. But for the time being, this is a good solution.

      Herzlichen Dank!!

      Abel

       
    • Jordan Fisher
      Jordan Fisher
      2008-04-27

      Howdy, I haven't quite gotten this to work. I save my csv from calc using Unicode encoding but nothing happens when I import the flash cards in OpenCards. Any thoughts on what I'm doing wrong?

      Cheers,
      Jordan

       
      • Holger Brandl
        Holger Brandl
        2008-04-27

        Give me the file (or at least a part of it). (use mediafire.com if you don't have own webspace)

        -holger

         
    • Jordan Fisher
      Jordan Fisher
      2008-04-27

      Hi Holger, here's a small snippet. http://www.mediafire.com/?sgfql7ixmxu

      Not sure if that one saved as UTF-16, not really sure how to check either.

      Cheers,
      Jordan

       
    • Jordan Fisher
      Jordan Fisher
      2008-04-27

      Indeed, sorry for that. It's working now, not sure what I was doing wrong at first.

      Thanks for all the help!