Hi,

I have just set up OpenBTS and am following the test procedure as outlined in http://openbts.org/site/wp-content/uploads/2014/07/OpenBTS-4.0-Manual.pdf section "F.2 Testing with Open Registration". I am using a USRP B200 over USB3. Sometimes my test phones register correctly, and sometimes they will not connect to the BTS at all. This behaviour seems to be arbitrary in nature, however, at any given point in time there seems to be at least one device that will connect without an issue.

Once devices have connected, they receive a message from number 101 as stated in "Location Updating" point 5. I have tried to reply to this message with a 10-digit number as stated in "Autoprovisioning" point 2, but I get a reply saying "Can't send your SMS to IMSI***************: 401 Unauthorized:" (where *************** is the correct IMSI for the device sending the message). Ddespite this error, sipauthserve seems to accept this registration. If I attempt to send an SMS from one of the connected devices to another, the sending device states that there is an error sending the message. I am also unable to send messages to devices from the OpenBTS CLI via the sendsms command (the command looks successful, but the device never receive the messages). I have also tried calling some of the numbers in /etc/asterisk/extensions-range-test.conf with no success.

The tmsis command at the OpenBTS CLI shows the devices that I have connected with correct IMSI/IMEI and an assigned TMSI.The following appears on the OpenBTS CLI when a device fails to connect:

ALERT 3865:3879 2014-07-31T15:55:28.7 TRXManager.cpp:565:clearHandover: NOHANDOVER(0) failed with status 1
ALERT 3865:3879 2014-07-31T15:55:28.7 GSML1FEC.cpp:575:handoverPending: C0T0 SDCCH/4-0-SACCH handover clear failed
ALERT 3865:3879 2014-07-31T15:56:14.7 TRXManager.cpp:565:clearHandover: NOHANDOVER(0) failed with status 1
ALERT 3865:3879 2014-07-31T15:56:14.7 GSML1FEC.cpp:575:handoverPending: C0T0 SDCCH/4-0 handover clear failed
ALERT 3865:3879 2014-07-31T15:56:14.7 TRXManager.cpp:565:clearHandover: NOHANDOVER(0) failed with status 1
ALERT 3865:3879 2014-07-31T15:56:14.7 GSML1FEC.cpp:575:handoverPending: C0T0 SDCCH/4-0-SACCH handover clear failed

Can you provide some insight into how I can diagnose or fix these issues? If I can provide any more information that could be of help, then please let me know and I shall get back to you as soon as possible.

Many thanks!