#254 error starting a scan

open
nobody
None
5
2010-09-16
2010-09-16
Alain Bonis
No

Hello,
I installed xsupplicant 2.2.1.487 on a Dell vostro 1510 laptop running vista 32 bits sp2 home premium ed.
Right after the install the U.I is displaying the different ssid's within reach of the laptop. This enabled me to configure the wpa2 ttls/pap connection to the eduroam network we use in our university.
Though, when I hit connect, nothing happens, and the radius server doesn't see any acces request coming in.
Moreover, after a reboot, the U.I doesn't display no networks, and hitting browse and refresh doesn't make any good.
I've tried with various versions of the intel wireless driver, but the results are the same.
I' m ready to provide more info and to do more testing, and I hope we can overcome this problem, as there is a real need for a vista/7 free supplicant.
Thank you for your work.
Regards.

Discussion

  • Alain Bonis
    Alain Bonis
    2010-09-16

    xsupplicant trouble ticket

     
  • Alain Bonis
    Alain Bonis
    2010-10-06

    About this error starting a scan :
    wlansvc would anymore not load after xsupplicant install. Uninstalling vmware server solved this problem . So I guess there may be some incompatibility between xsupplicant and vmware server.
    But, while the wireless networks are now visible, it's not possible to connect. I'll file another bug report for this.
    Regards.

     
  • Chris Hessing
    Chris Hessing
    2010-10-08

    Hi Alain,

    After the reboot, can you run "sc query open1x" and see if the protocol driver is running? Also, run "sc query wlansvc" to make sure the wlan service didn't die for some reason. If it did, then can you look in the event viewer to see if there is any information on why open1x or wlansvc isn't running?

    Thanks!

     
  • Alain Bonis
    Alain Bonis
    2010-10-11

    Here is the output you've asked me . But as I sais in my previous comment, scanning is now ok, but no connection to encrypted networks.

    C:\Users\admin>sc query open1x

    SERVICE_NAME: open1x
    TYPE : 1 KERNEL_DRIVER
    STATE : 4 RUNNING
    (STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
    WIN32_EXIT_CODE : 0 (0x0)
    SERVICE_EXIT_CODE : 0 (0x0)
    CHECKPOINT : 0x0
    WAIT_HINT : 0x0

    C:\Users\admin>sc query wlansvc

    SERVICE_NAME: wlansvc
    TYPE : 20 WIN32_SHARE_PROCESS
    STATE : 4 RUNNING
    (STOPPABLE, NOT_PAUSABLE, ACCEPTS_SHUTDOWN)
    WIN32_EXIT_CODE : 0 (0x0)
    SERVICE_EXIT_CODE : 0 (0x0)
    CHECKPOINT : 0x0
    WAIT_HINT : 0x0