Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

5.8 patch available

2008-11-24
2013-04-24
  • Bob Strachan
    Bob Strachan
    2008-11-24

    I updated from 5.6 to 5.8 and found that I couldn't get open IDE to go into debugger.

    The error message starts with:
    BEGIN failed--compilation aborted.
    Compilation failed in require at C:/Perl/lib/Win32.pm line 8.

    The solution.

    Download the patch at:
    https://sourceforge.net/forum/forum.php?forum_id=251666.  The patch is a new dbtemplate.txt that you swap out in your open Perl IDE. 

    There is still one more modification required.  You need to add "use Win32;" to the dbtemplate.txt file around line 45 (after the pod header). 

    Close and re-open open Perl IDE and it should now work.  Mine does.

    Note:  I found this on the web and thought I would share it with the users.  I had nothing to do with creating the dbtemplate.txt or open Perl IDE.

     
  • amol anil
    amol anil
    2013-01-15

    there is no patch at the given link .. can you please prvide the correct link path