Hello all :)

I've just recently managed to get hold of a compaq evo T20. It appears to be working fine and appears to have 64MB of flash, 96 MB of RAM (though windows at boot reports it as 93M) and runs windows nte 4.0. What I'm trying to do however is follow the various instructions on the internet and webpages to get a working linux on it. Snag is most of them seem to assume that you've done it before x.x .  (Not tried it before - !).

I've managed to get netxfer to appear by tapping "p" a few times at first power on and have found I have netxfer 09.00 10067 10068 10069 :)

First of all do I have to manually patch the T20s boot sector manually or is there I file I can download where this has already been done? Or do I have to go over the entire flash memory of the T20 with linux?

Also what's the easiest way of transferring that data to the T20 - I read stuff about BOOTP and PXE but I have no idea on how to do that (Never tried a network boot!).

Since I only have 96MB RAM in my T20 won't this be a bit tight on memory? Or is there a way to run linux off a USB memory stick but without having to load it all into ram first?

I also saw a slackware linux install and firmware here - ( 
ftp://li-la.de/incoming/bootp.bin_Compaq_Evo_T20.usbstick.installation-12.2_0.37.gz 
** dead link ** ) ,  ftp://li-la.de/pub/baldar/Compaq_Evo_T20/Firmwares/

....though again looking at the second link the problem is how to get GRUB across to the T20. BTW, are those 1GB usb stick linux installs - would they use all the memory on a 96MB T20?

My normal linux desktop is slackware 13.1, 64 bit.

Thanks for any help

ljones