What happens? What was the problem?

On 05/13/2014 12:56 PM, VEYSSIERE Nicolas wrote:

You are telling me to do something I don’t know how to do it.

 

I tried to execute the command "CFLAGS="-fPIC" CXXFLAGS="-fPIC" ./configure" in the 2 folders, but this doesn’t seems to do the trick, even after a make clean.

 

 

--

Nicolas V.

 

De : Alexander Sbitnev [mailto:alexander.sbitnev@gmail.com]
Envoyé : mardi 13 mai 2014 10:42
À : opalvoip-user@lists.sourceforge.net
Objet : Re: [Opalvoip-user] SIGSEGV on listening or calling

 

Those problems can be cured with some manual work. Rebuild autoconf and automake looks like overkill to me.
I've just recreate configure with autoreconf and reconfigure with "CFLAGS="-fPIC" CXXFLAGS="-fPIC" ./configure" inside opal/plugins/audio/G.722.1/libg722_1/
And just reconfigure with "CFLAGS="-fPIC" CXXFLAGS="-fPIC" ./configure"inside opal/plugins/audio/Opus/opus.

On 05/13/2014 12:32 PM, VEYSSIERE Nicolas wrote:

You where right, I am using tarball distribution, I then switch to SVN.

 

I was able to build ptlib without problems.

 

For opal, this is an other story, I add to install autoconf 2.69 from source and automake 1.13.4 (theses is not available in centos).

 

But the compilation failed anyway :

 

[LD] /root/opal/lib_linux_x86_64/plugins/opus/opus_ptplugin.so

/usr/bin/ld: /root/opal/plugins/audio/Opus/opus/.libs/libopus.a(celt.o): relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC

/root/opal/plugins/audio/Opus/opus/.libs/libopus.a: could not read symbols: Bad value

 

 

I don’t know if I am doing something wrong here, but I didn’t have this error for the tar version.

 

--

Nicolas V.