#4 fix loading of api libraries on MacOSX

3.2.0
closed
Mark Hessling
None
5
2012-08-14
2005-06-01
No

Current CVS compiles on 10.3.9 + Xcode 1.5. Thanks for making it
display MacOSX instead of Linux now. This small patch is for the
correct loading of dylibs under MacOSX.

"Changes to rexxapi/unix/SubcommandAPI.cpp are original work of
René Vincent Jansen, rvjansen@xs4all.nl."

Discussion

  • Mark Hessling
    Mark Hessling
    2005-06-01

    Logged In: YES
    user_id=86185

    This patch has highlighted some other OSX issues in
    SubCommandAPI.cpp. Line 1361 appends ".so". This should also
    have an #ifdef APPLE wrapper.
    The hard-coded "/usr/lib" also needs to be specified from
    the autoconf $(prefix) variable.
    I will sort these out shortly.

     
  • Mark Hessling
    Mark Hessling
    2006-01-19

    Logged In: YES
    user_id=86185

    Implemented changes to allow shared libraries to be loaded
    on multiple platforms; controlled via autoconf. Unable to
    test on OSX.

     


Anonymous


Cancel   Add attachments