I like the spaces.
"---attr = value---"
is easier to read imho.

From: Mark Miesfeld [mailto:miesfeld@gmail.com]
Sent: 03 March 2012 05:10
To: Open Object Rexx Users
Subject: [Oorexx-users] Railroad tracks for attributes in the ooDialogreference manual

Hi All,
Madou just supplied the project with a number of patches fixing my zillions of spelling errors in the 4.2.0 ooDialog doc.  Which is very much appreciated.
One thing he brought up was the railroad track syntax diagram I've been using for attributes:
He said: the format "---attr-=-value---" which is somewhat difficult to read
and he suggested compacting it to:  "---attr=value---"

It's a good point that it's difficult to read, but my first instinct would be to drop the two dashes rather than compacting it.  Like this instead:

"---attr = value---"

I always put a space around an equals sign, so none of the code snippets in the doc will have code like:


it is always:

self~initCode = 1

I just compiled the doc, and in the dialog object chapter, for the autoDetect, constDir, dlgHandle, factorX, and factorY I put a apace around the equals sign in the railroad track. I left all the other ones compacted, so it would be easy to compare how the two formats actually look like in the doc.

I put that compiled doc on SourceForge with the ooDialog downloads.  I'd appreciate anyone that wanted to take a look and comment on which format they would choose.
The file on SourceForge is: oodialog-r7626.pdf which is the latest version.  The section to look at to see the differences is:

3.4. Attribute Methods

Mark Miesfeld