I’ve been programming REXX since the first versions on VM/CMS which replaced EXEC and EXEC2.  The “I” stands for “Intermediates”, not “Interactive”.  And yes, I concur that the “?” has always been required for an interactive trace from the birth of REXX.  I can’t say that some version somewhere didn’t do this, but I would think it would violate the language standard.

 

Best Regards, -Mark

 

From: Rick McGuire [mailto:object.rexx@gmail.com]
Sent: Wednesday, July 10, 2013 4:28 PM
To: Open Object Rexx Announcements
Subject: Re: [Oorexx-announce] Failure

 

No, the ? prefix has always been required for interactive debug, even on VM/CMS. 

 

Rick

 

On Wed, Jul 10, 2013 at 5:24 PM, <William_Lightner@jbhunt.com> wrote:


I'm not particularly current in the OOREXX implementation, but I spent a lot of years doing Rexx in VM/CMS.


TRACE I         -- 'I' for 'Interactive'.  Pauses after each instruction.

On some other platforms (most DOS/Windows implementations I've seen) there's also the '?' prefix, but I don't recall having it, let alone needing it in VM/CMS.  On the other hand, the last time I worked in that environment was 1996....


Does this help?



William Lightner
------------------------------------------------------------------------------
See everything from the browser to the database with AppDynamics
Get end-to-end visibility with application monitoring from AppDynamics
Isolate bottlenecks and diagnose root cause in seconds.
Start your free trial of AppDynamics Pro today!
http://pubads.g.doubleclick.net/gampad/clk?id=48808831&iu=/4140/ostg.clktrk
_______________________________________________
Oorexx-announce mailing list
Oorexx-announce@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/oorexx-announce