The new method of the ResourceImage class currently uses 1 required and 1 optional argument to specify which resource image is to used to instantiate the ResourceImage object. It is not necessary to use 2 arguments. One argument is sufficient.
The new() method should be enhanced to only need the first argument. This would simplify its use for the programmer. The original argument meanings would still be supported for backwards compatibility, but for programmers writing new code, the new meanings for the first arg will make it easier.
Note: the code and testing has already been done, just opening this so that the doc is not forgotten.