over and over again, simple tests to find out whether a needle is contained in a haystack are performed in code, in the following fashion:
IF haystack~pos(needle) > 0 THEN, or
IF haystack~wordPos(needle) > 0 THEN, etc....
A string method "contains" would greatly enhance code readability and follow the human centric philosophy of rexx. The aboce code would look like
IF haystack~contains(needle) THEN, or
IF haystack~containsWord(needle) THEN, etc....