#1255 NOVALUE Triggers During Casual Accesses

None
closed
nobody
None
none
3
2014-08-28
2014-04-04
MarcIrvin
No

I recently set up a new Win7 64bit 3.4GHz server with ooRexx V420. I noticed that my rexx apps were getting novalue errors while doing the same commands I run on my Win7 64bit 2.3GHz server with ooRexx V411. I traced the problem to find out that novalue was being triggered on the new machine even during a "var.0 = var.0" or "datatype(var.0)" commands, but not on any of my other rexx servers. I have 10 different machines going all the way back to WinXP. Naturally I will not be sending traces from all those machines to prove my point. I have attached two .txt files, one that works on many releases of ooRexx and on showing the failure.

1 Attachments

Discussion

  • Rick McGuire
    Rick McGuire
    2014-04-04

    You are going to need to provide a sample program that reproduces the value. From the traces you provided, the 4.1.1 behavior is the incorrect behavior, not the 4.2.0 one. If the variable !v.0 actually is uninitialized as the traces appear to show, then the NOVALUE condition should be trigered. However, I've not been able to reproduce this using a simple program.

     
  • Rick McGuire
    Rick McGuire
    2014-04-15

    • Group: v4.2.0 --> None
     
  • MarcIrvin
    MarcIrvin
    2014-05-01

    OK.

     
  • Rick McGuire
    Rick McGuire
    2014-08-28

    • status: open --> closed
     
  • Rick McGuire
    Rick McGuire
    2014-08-28

    Closing this since no additional information was provided.

     


Anonymous


Cancel   Add attachments