#3 examples 1 through 3 don't work

ooolib 0.1.x
closed-works-for-me
Joseph Colton
General (7)
5
2003-10-25
2003-09-23
Anonymous
No

Hi,

I downloaded ooolib and ran the 5 example programs...
example1, example2, and example3 generated .sxc files
but when I try to open them with oocalc v1.0.2 (for
redhat linux 9) I get the message

Error loading document
file://home/blah/ooolib/examples/10642412342.sxc:
Read-Error.
Error in file structure while importing.

The oowriter files created by example4 and 5 seem to
work OK.

best,

hihijoy12.4.joek@spamgourmet.com

Discussion

  • The file created by example3

     
    Attachments
  • Joseph Colton
    Joseph Colton
    2003-09-26

    • assigned_to: nobody --> chiasmus1
    • status: open --> open-accepted
     
  • Joseph Colton
    Joseph Colton
    2003-09-26

    Logged In: YES
    user_id=656103

    Examples 1-3 create the spreadsheet documents. 4-5 are writer
    documents. The Mac OS X version of OpenOffice.org also reports
    the same error.

     
  • Joseph Colton
    Joseph Colton
    2003-10-03

    Logged In: YES
    user_id=656103

    The file seems to have a problem, but the examples work on my
    machine. I will need to take a closer look at the file to see if I
    can figure out what went wrong.

     
  • Joseph Colton
    Joseph Colton
    2003-10-03

    • status: open-accepted --> closed-postponed
     
  • Joseph Colton
    Joseph Colton
    2003-10-25

    • status: closed-postponed --> closed-works-for-me
     
  • Joseph Colton
    Joseph Colton
    2003-10-25

    Logged In: YES
    user_id=656103

    It looks like the problem was caused by having asian
    characters in the styles.xml file. The characters were in
    the currency tags. Apparently the different versions of
    Perl handled the characters differently. This caused
    documents built on one machine to form correctly while
    documents on another machine that did not handle asian
    characters properly to form incorrectly. Hopefully the
    problem has been fixed.

     
  • Joseph Colton
    Joseph Colton
    2003-10-25

    Logged In: YES
    user_id=656103

    It looks like the problem was caused by having asian
    characters in the styles.xml file. The characters were in
    the currency tags. Apparently the different versions of
    Perl handled the characters differently. This caused
    documents built on one machine to form correctly while
    documents on another machine that did not handle asian
    characters properly to form incorrectly. Hopefully the
    problem has been fixed.