Installation Help for once:radix Win XP SP2

ecupirates
2009-10-26
2013-04-23
  • ecupirates
    ecupirates
    2009-10-26

    once:radix on Windows XP SP2

    While trying to install once:radix on my machine I encountered two situations where I had to do research to get once:radix installed and working correctly.  One of the issues occurred during the Tomcat install while the other happened while installing PostgreSQL.

    Tomcat Install

    The steps provided to us for the Tomcat install are all correct the issue occurred while I was trying to get the Tomcat started.  My computer was missing a file named MSVCR71.dll which was suppose to be installed and placed inside the C:\windows\system 32 folder.  I found this file on the website:

    http://www.icurtain.co.uk/blog.php?article=92

    You can download it and move it to the designated folder.

    Once I placed this file inside the System 32 folder Tomcat started correctly.  Remember this is for Win XP SP2. It might not have been an issue for Win XP SP3, Vista, or Windows 7.

    PostgreSQL Install

    This is one of the steps:

    One of the settings in the file pg_hba.conf specifies whether PostgreSQL will require connections to provide an encrypted password. The IP address of all Tomcat servers connected to PostgreSQL must be set to 'trust', to allow the automatic backup function to work correctly.

    Note: Only the specific IP address of Tomcat should be set to 'trust'. Do NOT use global addressing when specifying 'trust' in pg_hba.conf.

    If PostgreSQL is not used by other applications, drag a copy of the file 'pg_hba.conf' from the directory ..\onceradix\extras\windows\ in the deployment package to ..\onceradix\postgres\data\pg_hba.conf to replace the current file as it is already configured for you.

    Otherwise, if PostgreSQL is used by other applications, , using a simple text editor, change the default 'IPv4' and 'local' connection methods from 'md5' to 'trust' in the file ..\onceradix\postgres\data\pg_hba.conf.

    Copying and pasting the pg_hba.conf over the file from \onceradix\postgres\data\pg_hba.conf did not work for me.  I had to take the second option where I went into the file manually and changed it to 'trust'. In hindsight, this may have been due to access privileges.

    After following the steps for once:radix and making these two changes in my process I was successful in getting once:radix to work on my machine.

    I hope this helps others who might be experiencing similar issues. 

    Thank you to everyone and once:radix for creating a wonderful program and moving me away from FileMaker!