how to run gstreamer-plugins

uday
2008-11-03
2013-06-05
  • uday
    uday
    2008-11-03

    Hi all,
       i  have installed gstil-plugins-B-0.3..but iam unable run the plugins..
    but in README file he has given like this..

    To run these plugins:

    gst-launch-0.10 filesrc location=filename.mp3 ! ILMp3Dec ! filesink location=output_filename.pcm

    gst-launch-0.10 filesrc location=filename.mp3 ! ILMp3Dec ! ILAlsaSink

    gst-launch-0.10 filesrc location=filename.mp3 ! ILMp3Dec ! ILVolume volume=0.9 ! ILAlsaSink

    gst-launch-0.10 filesrc location=filename.mp3 ! ILMp3Dec ! ILVolume mute=TRUE ! ILAlsaSink

    Actually i didn't understand wat the terms FILESRC,LOCATION-FILENAME.MP3 means???
    wat i have to write instead of filesrc,location???
    If anyone have any idea on this please try to resolve my confusion..

    Thanks & Regards
    Uday kiran

     
    • Pankaj Sen
      Pankaj Sen
      2008-11-04

      Hi All,

      For your information gstilplugins-B.0.3 gstreamer plugin is obsolete. We are no more supporting Gstreamer plugin.

      For latest plugins pls visit:-

      http://www.freedesktop.org/wiki/GstOpenMAX

      Thanks & Regards,
      Pankaj

       
    • uday
      uday
      2008-11-04

      Hi pankaj,

      Thanks for the reply..

      Is it possible to run video applications using gst-openmax-0.10.0.4 and libomxil-bellagio-0.9.1 in ubuntu platform.
      If we r installing these two packages iam not getting any executable files getting only shell scripts..
      where as with libomxil-B-0.3.3  am getting executables.. 
      Is there any problem with Ubuntu..

      Thanks in advance
      Uday

       
    • Pankaj Sen
      Pankaj Sen
      2008-11-04

      Hi Uday,

      Again, for all gst-omx related queries pls consult freedesktop.org. We are not supporting gst-omx plugin.

      You may not need both but 0.3.3 and 0.9.1 releases can work independently. Read README file.

      Do make check to make application.

      Regards,
      Pankaj