gstilplugins-B-0.3+libomxil-bellagio-0.9.1 ??

Ram K
2008-11-03
2013-06-05
  • Ram K
    Ram K
    2008-11-03

    Hi  all

    Can any one explain what is the Dependency between libomxil-bellagio-0.9.1 and  gstilplugins-B-0.3 ??

    Which one i need to install first ? I am able to install  libomxil-bellagio-0.9.1 successfully and able to run some of audio test cases.
    whether i need to install gstilplugins-B-0.3 for running Test applications (mainly Video)?

    Where  i can fine theoretical information on link between these 2 components.

    Thanks

     
    • Giulio Urlini
      Giulio Urlini
      2008-11-03

      Hi,
      the gst omx is built to use a standard OpenMAX interface, so it does not matter the version of Bellagio. Practically you can have some issues due to implementation errors.
      In any case you need to install the Bellagio library before, and after that use the gst omx cplugins.

      BR,
      Giulio

       
    • Ram K
      Ram K
      2008-11-03

      Hi Giulio,

      Thanks for your reply.

      Now able to install gstilplugins-B-0.3 also.

      But when i am run these plugins: like
      gst-launch-0.10 filesrc location=sample.mp3 ! ILMp3Dec ! filesink location=output.pcm
      i am getting a warning like below.
      WARNING: erroneous pipeline: no element "ILVorbisDec"

      Even this is same for when i am running the test application also.

      what can be the issue ? any thing need do ?

       
      • Giulio Urlini
        Giulio Urlini
        2008-11-03

        You have to fix the GST_PLUGIN_PATH env variable to point to the gst omx plugins. They are usually located in /usr/local/lib/....
        And don't forget to run
        omxregister-bellagio
        In this way the component would be found

         
    • Pankaj Sen
      Pankaj Sen
      2008-11-04

      Hi All,

      For your information gstilplugins-B.0.3 gstreamer plugin is obsolete. We are no more supporting Gstreamer plugin.

      For latest plugins pls visit:-

      http://www.freedesktop.org/wiki/GstOpenMAX

      Thanks & Regards,
      Pankaj

       
    • Ram K
      Ram K
      2008-11-04

      Hi Pankaj,

      I have a small doubt ...!

      I am new to this project. I installed libomxil-bellagio-0.9.1 (Latest one i think).
      is there any need to install libomxil-B-0.3.2 also. I think this is older version ... right ?

      why i am asking this is from your link i downloaded gst-openmax-0.10.0.4 files and Installed the package.
      In that README file is pointing to libomxil-B-0.3.2 .

      Please clarify this.

      and one more thing if i want to debug the test applications what is the best debugger you suggest ?

      Thanks for your Help

      Regards,
      Sriram

       
    • Pankaj Sen
      Pankaj Sen
      2008-11-04

      Hi Sriram,

      gst-openmax-0.10.0.4 is based on libomxil-B-0.3.2  and work with libomxil-B-0.3.4.

      To make it work with libomxil-bellagio-0.9.1 you may have to do some modification in gst code. In omx/gstomx.h update as

      //#define DEFAULT_LIBRARY_NAME "libomxil.so.0"
      #define DEFAULT_LIBRARY_NAME "libomxil-bellagio.so.0"

      from bellagio 0.9.1 onwards library name have change from libomxil to libomxil-bellagio.

      For debugging in linux you can use gdb as command line or ddd as GUI.

      Regards,
      Pankaj