No preview for manual cropping

  • Jul


    With OGMRip 0.13.7 on debian sid, I don't have any preview for manual cropping. I forgot something ?


  • No, you didn't forgot anything. This is an issue that has been fixed in subversion. Perhaps I should release 0.13.8…

  • Jul

    Ok thanks.
    And thanks for the soft…

  • kickback

    I've been seeing this problem for a while now. I've installed 0.13.8 from a third party rep and just now built it from source.
    The manual crop preview image is missing with the default broken image in it's place.

    Having tried to set manual cropping params with a dvd, dvd structure and a dvd iso, it looks as though there's
    no applicable console output but running with -debug does yield this:

    Cannot find codec 'mpegvideo' in libavcodec…
    Cannot find codec matching selected -vo and video format 0x10000002.

    This is on kubuntu 12.04 with 3.2.0-29-generic x86_64
    The version in the ubuntu rep is similarly broken. (0.13.6?)

  • kickback

    Having dug around a little, it seems there are two problems: for some reason, ogmrip was using /media as the default temporary directory and didn't notice that this wasn't writable. That one was a run time fix as I could just select another

    The second problem is that my mplayer (MPlayer svn r34540 (Ubuntu)) chokes when using "-vc ffmpeg12" (the error message from the previous post).

    The key section is here in src/ogmrip-crop-dialog.c:

    if (MPLAYER_CHECK_VERSION (1,0,0,8))
        g_ptr_array_add (argv, g_strdup ("-vc"));
        g_ptr_array_add (argv, g_strdup ("ffmpeg12"));
        g_ptr_array_add (argv, g_strdup ("-frames"));
        g_ptr_array_add (argv, g_strdup ("1"));
        g_ptr_array_add (argv, g_strdup ("-frames"));
        g_ptr_array_add (argv, g_strdup ("3"));
        g_ptr_array_add (argv, g_strdup ("-sstep"));
        g_ptr_array_add (argv, g_strdup ("1"));

    In my case at least, removing -vc ffmpeg12 was enough to get everything working so I removed the conditional check
    above and default to the secondary case. It's not a general purpose fix so I won't send a patch but if you want some more
    information just let me know.

    Thanks for the great app.

  • Ernerestre

    Hello, I am new to OGM and Linux, and I have run into a problem. I just installed the latest Ubuntu 13.04 I think and got the 0.13.8 version from the Software Center which does not have the preview. I got the latest version from SourceForge and also tried to do what was stated above and was not able to compile either of them. I keep getting a message and I am not sure what to do next. I run the configure command for both and get the same message.

    No package 'glib-2.0' found
    No package 'gobject-2.0' found
    No package 'gmodule-2.0' found
    No package 'gio-2.0' found
    No package 'enca' found

    I am not sure what I need to do next to fix this issue.

  • You must install development versions of glib, enca, libxml, gtk+, libglade, gconf, libdvdread.