#163 Line Strip not connected

gl... Functions
closed-remind
nobody
Defect (99)
5
2007-06-01
2006-02-08
Anonymous
No

I have modified the lines example from the redbook to
draw a 'C' character with a Line Strip. The Lines are
not connected on the screen.

glColor4f (1.0, 1.0, 1.0, 1.0);
{
GLfloat v[16];
v[0] = 107.74;
v[1] = 109.93;
v[2] = 105.81;
v[3] = 111.9;
v[4] = 101.94;
v[5] = 111.9;
v[6] = 100;
v[7] = 109.93;
v[8] = 100;
v[9] = 101.99;
v[10] = 101.94;
v[11] = 100;
v[12] = 105.81;
v[13] = 100;
v[14] = 107.74;
v[15] = 101.99;
glVertexPointer(2, GL_FLOAT, 0, v);
glEnableClientState(GL_VERTEX_ARRAY);
glDrawArrays(GL_LINE_STRIP, 0, 8);
}

Even is I round the value, the lines won't get
connected.

Discussion

  • Screen Shot

     
    Attachments
  • Logged In: YES
    user_id=618887

    This *might* have been fixed. I'm awaiting the OK of the
    conf. test submission this week and plan to upload a new
    release once I get the results.

    - HM

     
  • Logged In: YES
    user_id=618887
    Originator: NO

    I know that this is an old issue: There have been fixes to similar issues being committed recently. Does the issue still exist for the current code in the trunk?

     
    • status: open --> pending-remind
     
    • status: pending-remind --> closed-remind
     
  • Logged In: YES
    user_id=1312539
    Originator: NO

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).