Compilation problem

Help
Alvaro
2009-01-19
2013-04-18
  • Alvaro
    Alvaro
    2009-01-19

    I'm getting the following errors when trying to compile ocaml-xml:

    $ make build
    <doing action='build' dirs='xml oxp4 test examples'>
    <entering dir='xml'>
    ocamlc.opt -pp camlp4o -g -w p  -c xmlData.mli
    ocamlc.opt -pp camlp4o -g -w p  -c xmlHandler.mli
    ocamlc.opt -pp camlp4o -g -w p  -c xml.mli
    ocamlc.opt -pp camlp4o -g -w p  -c xmlData.ml
    ocamlc.opt -pp camlp4o -g -w p  -c genParser.ml
    ocamlc.opt -pp camlp4o -g -w p  -c dtdParser.ml
    ocamlc.opt -pp camlp4o -g -w p  -c xmlValidator.ml
    ocamlc.opt -pp camlp4o -g -w p  -c xmlParser.ml
    ocamlc.opt -pp camlp4o -g -w p  -c xml.ml
    ocamlopt.opt -pp camlp4o -w p  -c xmlData.ml
    ocamlopt.opt -pp camlp4o -w p  -c genParser.ml
    ocamlopt.opt -pp camlp4o -w p  -c dtdParser.ml
    ocamlopt.opt -pp camlp4o -w p  -c xmlValidator.ml
    ocamlopt.opt -pp camlp4o -w p  -c xmlParser.ml
    ocamlopt.opt -pp camlp4o -w p  -c xml.ml
    ocamlc.opt -pp camlp4o -g  -linkall -custom -a -o ../../lib/xmlcore.cma   xmlData.cmo genParser.cmo dtdParser.cmo xmlValidator.cmo xmlParser.cmo xml.cmo
    ocamlopt.opt -pp camlp4o -linkall         -a -o ../../lib/xmlcore.cmxa xmlData.cmx genParser.cmx dtdParser.cmx xmlValidator.cmx xmlParser.cmx xml.cmx
    cp -f xml.mli ../../lib/xml.mli
    cp -f xml.cmi ../../lib/xml.cmi

    <entering dir='oxp4'>
    ocamlc -pp camlp4orf -I +camlp4 -c q_xml.ml
    File "q_xml.ml", line 63, characters 23-29:
    Unbound constructor Syntax
    make[1]: *** [build] Error 2

    <entering dir='test'>
    ocamlc -g -o ./test ../../lib/xmlcore.cma  -pp "camlp4o ../../lib/q_xml.cmo" -I ../../lib test.ml
    Camlp4: Uncaught exception: DynLoader.Error ("../../lib/q_xml.cmo", "file not found in path")

    Preprocessor error
    make[1]: *** [build] Error 2

    <entering dir='examples'>
    ocamlc   -g -o ./nothing  ../../lib/xmlcore.cma  -pp "camlp4o ../../lib/q_xml.cmo" -I ../../lib nothing.ml
    Camlp4: Uncaught exception: DynLoader.Error ("../../lib/q_xml.cmo", "file not found in path")

    Preprocessor error
    make[1]: *** [build] Error 2

    Any idea of what could be happening?

    Thanks in advance

    Alvaro

     
    • Which OCaml version are you using ?

      Didier

       
      • This problem occurs with version 3.11.1 of OCaml. It works fine for previous version but not the last one (analysis in progress)