Erro Install 0.71

Help
Anonymous
2012-11-06
2014-03-31

  • Anonymous
    2012-11-06

    OpenBiblio Installation:

    Database connection is good.
    Building OpenBiblio tables, please wait…
    Database Query Error - You've Probably Found a Bug

    Wrong number of result rows: expected 1, got 0

    Please give all the information on this page to your support personnel.

    Query SELECT * FROM `settings` failed. The DBMS said this:

    No DBMS Error
    Debug Backtrace (most recent call first):

    /home/mmcriaco/public_html/biblioteca/classes/Error.php:137 FatalHandler->printBackTrace()
    /home/mmcriaco/public_html/biblioteca/classes/Error.php:105 FatalHandler->dbError('SELECT * FROM `settings` ', 'Wrong number of result rows: expected 1, got 0', 'No DBMS Error')
    /home/mmcriaco/public_html/biblioteca/classes/Query.php:69 Fatal->dbError('SELECT * FROM `settings` ', 'Wrong number of result rows: expected 1, got 0', 'No DBMS Error')
    /home/mmcriaco/public_html/biblioteca/classes/InstallQuery.php:54 Query->select1('SELECT * FROM `settings` ')
    /home/mmcriaco/public_html/biblioteca/classes/InstallQuery.php:69 InstallQuery->_getSettings('')
    /home/mmcriaco/public_html/biblioteca/install/install.php:71 InstallQuery->getCurrentDatabaseVersion()

     
  • You must have been trying to select a translation that has not been updated for version 0.7.1.

    I think  "English" will work, afterwards you can change the language in tab Admin > Library Settings.
    The disadvantage of choosing the language afterwards might be that some text is not translated.
    So that is the other option: update the translation, start by making a copy of obiblio/locale/en/

     
  • pablo
    pablo
    2012-12-10

    Hi there,
    I had the same problem. And I thought it had to do with the language chosen , so I decided to try again but selecting english this time. But the problem is that now, I cannot run the script anymore!! The screen with the "No DBMS Error
    Debug Backtrace (most recent call first):" appears  when I try to run the index.php script again!
    Please, I need some help.
    Thanks a lot

     
  • Hello Pablo,

    > And I thought it had to do with the language chosen

    You are saying you had the option to choose another language… but up to now (including 0.7.1) all our official releases do not offer languages additional to English. So… where did you get the translation? Do you have a download link for the translation?

     
  • pablo
    pablo
    2012-12-11

    Hans,
    first of all, thanks a lot for your reply. It's very kind of you.
    Second, I think I should have started the post with "I'm working on a spanish translation of OB 0.7.1…"  but it was almost 3 am, I'd been working the whole day and I was very tired! =)
    As I describeed in the post, once my first version faiiled to install, I tried to debug it but I could not run the installing script again. Instead of going to the page "Select language" the message "No DBMS Error Debug Backtrace (most recent call first):" appeared again and again. Is this normal?
    The first thing I should ask is then this: is it possible to make an install of OB choosing another language? (with a correctly done translation, of course)
    The second thing is this: if installation fails because of errors in the (tweaked) locale file, is it possible to reinstall OB somehow?
    Many, many thanks for your help.
    Kind regards.
    Pablo

     
  • pablo
    pablo
    2012-12-12

    Hi again,
    and thanks for the reply. I already knew those links, and since most spanish translations seemed to be outdated, I decided to do one myself for 0.7.1. It's pretty advanced by now and as soon as it is polished I will share it with the rest of the community. I have a few questions about the translation, but I guess I should open a new thread instead of hijacking this one, even though it has somehow drifted in this direction, right?
    Concerning the DBSM error, I finally solved it by purging the database and creating a new one. This time I chose english for the installation and worked  over it from scratch instead of trying to adapt the existing translation.
    In any case, as the second post seem to imply, does it make any difference to install in english and then switch to spanish via library settings instead of installing directly in spanish? (supposing no errors in the spanish files :)
    Cheers to all!

     
  • Yes, there can be a difference when you install in a language and switch to a different language afterwards using library settings. This is because our 0.x.x branch creates "domain" definition tables during install and the information in those tables is not changed when a running OpenBiblio is switched to a different language. This is an issue, because translation strings in several domain tables really should be translated when the language is switched.

    So the recommendations are:
    * Always try installing your preferred language first. Do not expect a user controlled language switcher before the translation issues are fixed in our source code.
    * If anything goes wrong when installing a language other than default English: delete the database and start over again, but only after fixing the domain tables in the translation

    /locale/<2 letter country code>/sql/<version>/domain/
    

    The development team does not expect to fix the translation issues for the 0.x.x branch.
    Translations in the 10-wip branch are better, but here "wip" means Work In Progress and better is still not perfect.

     
  • hi, i cant install pleas help me, this is the error displayed when i try ti install, i working on
    winxp
    Apache Version :2.4.4
    PHP Version :5.4.16
    mysql5.6.12

    on wampserver

    thanks a lot

    OpenBiblio Installation 7.2:

    Book media directory already exists & work properly.
    Book cover directory already exists & work properly.
    Temporay cover lookup directory already exists & work properly.
    foto member lookup directory already exists & work properly.
    foto autor directory already exists & work properly.
    Book digitales directory already exists & work properly.
    Database Query Error - You've Probably Found a Bug
    Wrong number of result rows: expected 1, got 0

    Please give all the information on this page to your support personnel.

    Query SELECT * FROM settings failed. The DBMS said this:

    No DBMS Error

    Debug Backtrace (most recent call first):

    C:\wamp\www\espa32\classes\Error.php:140 FatalHandler->printBackTrace()
    C:\wamp\www\espa32\classes\Error.php:108 FatalHandler->dbError('SELECT * FROM settings ', 'Wrong number of result rows: expected 1, got 0', 'No DBMS Error')
    C:\wamp\www\espa32\classes\Query.php:72 Fatal->dbError('SELECT * FROM settings ', 'Wrong number of result rows: expected 1, got 0', 'No DBMS Error')
    C:\wamp\www\espa32\classes\InstallQuery.php:54 Query->select1('SELECT * FROM settings ')
    C:\wamp\www\espa32\classes\InstallQuery.php:69 InstallQuery->_getSettings('')
    C:\wamp\www\espa32\install\install.php:207 InstallQuery->getCurrentDatabaseVersion()

     
    • Jhonny, assuming you have followed steps 5-9 from install_instructions.html, can you delete all tables from the database? Then you run the install script again (in the browser), and make sure to select English. Do not use a translation when installing because incomplete translations can cause errors.

       
  • Thanks for your response, I delete everything including databases, but now the error that I have is that it does not recognize the username and password assigned, recognize the name of the database. This is the content of database_constants.php


    define("OBIB_HOST", "localhost");
    define("OBIB_DATABASE", "openbiblio");
    define("OBIB_USERNAME", "jhonny");
    define("OBIB_PWD", "3153044");


    and this is the error message page for floor installation

    OpenBiblio 0.7.1 Installation
    The connection to the database failed with the following error.

      Cannot select database.: Access denied for user ''@'localhost' to database 'openbiblio' -- FULL SQL: Selecting database...
    

    tanks a lot.

     
  • Perhaps you still need to do step 6 from install_instructions.html

    grant all privileges on openbiblio.* to jhonny@localhost
    identified by '3153044';
    
     


Anonymous


Cancel   Add attachments