Wow I didn't think I'd get this much of a response. :D

> Hi, PowerPup here. I finally got my 4gig hard drive to work with my 6100
> mac. (Using the Drive Setup hack.)
>
> Anyway, I'm trying to get a linux 2.4 kernel to boot up in order to run the
> debian installer.
> Using BootX 1.1.3 (Only version I can get to work on my 6100.) I've been
> able to boot the 2.4.27 and 2.4.32 kernels. Only the 2.4.27 kernel will get
> passed the "arch:exit" when I try to boot with the ramdisk image, and then I
> get the following error:
>
> RAMDISK: Compressed image found at block 0
> Freeing initrd memory: 2603k freed.
> VFS: Mounted root  (ext2 filesystem) read only
> mount: Mounting none on /dev failed  : No such device
> Kernel panic: Attempted to kill init!
> <0>Rebooting in 180 seconds..
>
> My 6100 has a Newer Technologies NuPowr G3 card, with an AV video card.
>
> Using Mklinux bootloader. I've only got the debian woody installer mach
> kernel to boot. and it only ends up at a grey screen.
>
> Any ideas and help on a good combination of kernel and ramdisk image would
> be greatly appreciated.
>
>
> PowerPup.
>AFAIR there have been no reports from other users who own a 6100 with a
>G3 upgrade since the project focused on G3 upgrades.
>Did you build your own 2.4.32-based kernel? Or is it the ready-made
>miBoot ISO image / BootX kernel from the download section on the project site?

>The project page lists a special miBoot-version provided by Jeff Carr,
>which is supposed to work with the AV video card. (I just realized that
>all direct download links from our web space are broken. I'll try to put
>all bootloaders in the download section)

I've tried it with the G3 card disabled too. Same results. (So it doesn't seem to be the card. :D )
I've been using the ready-made BootX kernel from the download section on the project site.
MiBoot (any version) doesn't seem to work on the 6100, all I get is a flickering "Welcome to Macintosh" box. Like the one you'd see in mac os 7.5.


>Not sure whether this helps, but did you try to make use of the
>"arielfb" frame buffer driver? Please see nubus-pmac.sf.net for some
details.
>I guess most of the provided ISO images are hard-coded to
video=nbpmacfb. It can be configured from the miBoot boot menu though.

>
Cheers,

>Florian

No, I left it blank. (although I think I tried it before editing the config file) I'll see it does anything.


>If you are time-wealthy, you may be better off helping him test and
>such so we can get the 2.6 kernel and a recent Linux distro (e.g.
>Debian Lenny) working on the 6100.

>I'm in the same boat hardware-wise. I have a Power Macintosh 6100/66
>with 72MB RAM and a G3 card. However, I really won't have time to
>tinker with it any time soon.

>Joey

I would love to help out testing the 2.6 kernel.
I also have a PB 3400 and 5300.

I want to get the 2.4 working so I'd have some experience on
getting Linux to work on my 6100 and have a "testing" environment.

>I just was browsing through some 2.4 pre-releases, which never made it
>on the project site:

http://nubus-pmac.sourceforge.net/nubus-pmac/test/2.4.35/

>Unfortunately SourceForge seems to have turned directory listings turned
>off, so here are the direct links:

http://nubus-pmac.sourceforge.net/nubus-pmac/test/2.4.35/Mach Kernel
http://nubus-pmac.sourceforge.net/nubus-pmac/test/2.4.35/miboot-2.4.35.1.iso
http://nubus-pmac.sourceforge.net/nubus-pmac/test/2.4.35/miboot.image
http://nubus-pmac.sourceforge.net/nubus-pmac/test/2.4.35/miBoot-2.4.35.1-nfs-floppy.img
http://nubus-pmac.sourceforge.net/nubus-pmac/test/2.4.35/vmlinux.gz

>May be it's worth a try on the 6100.

>Cheers,

> Florian

Thanks! I tested them.

Miboot doesn't work (like the rest) on the 6100.
The BootX kernel isn't recognized by version 1.1.3. (readme says it only detects ELF32 files?)
(The 1.1.3 is only version I can get to open and properly boot kernels.
1.2b1 detects it. but it freezes when ever I try to boot any kernel.)
The Mach Kernel DOES work! But the is no ramdisk image built into it.
So I get the "can't mount VFS/root not found" error. (Can't recall offhand exactly what it says.)

So If I (or someone else since I haven't tried doing this before)
can build the 2.4.35 kernel with the debian sarge ramdisk,
hopefully it should work. :D

Thanks to all of you for your help!

Ben.


Windows Live™ SkyDrive™: Get 25 GB of free online storage. Get it on your BlackBerry or iPhone.