Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

nsthdinstall with --modules "sg....."

NST
Phillbo
2005-02-12
2012-12-05
  • Phillbo
    Phillbo
    2005-02-12

    Hi,
    Hope someone can help, I'm installing NST to the harddrive of a Dell 1750, dual XEON, SCSI, RAID1. The CD Boots fine and after modprobe megaraid I can see partitions listed under fdisk -l.
    sda1-4 with sda1 as boot and sda2 and swap sda3 and 4 as data... I use the command line:
    nsthdinstall --modules "sd_mod scsi_mod sg megaraid" --device /dev/sda1 --format --grub-install
    and I get an error statine that scsi_mod sg megaraid are not valid modules. I tried changing them around, but same result, it would recognize the first module and not the last 3... I tried seperating them with commas with spaces with semi-colons and all 3 with and without double quotes surrounding the modules but same result.
    I thought... well the first 3 installed themselves... maybe, just add the megaraid module, everything copied over fine and at the end success was stated, but upon reboot, (grub did show up and I left everything as default) and letting grub boot through, megaraid errored out and it gave me a kernel panic not being able to find sda1. I also tried modules none... no boot from HDD.
    Any thoughts would be appreciated.

    -Phill

     
    • There is a bug in the script when multiple modules are specified (my bash scripting needs to improve and it would help if I figured out a mechanism to automate the testing of the scripts).

      This will be fixed in the 1.2.1 release.

      If you want to fix it temporarily, try copying the nsthdinstall script to the /tmp directory and change the line:

      process_args $*

      To:

      process_args "$@"

      Then run the modified script.

      Thanks for reporting this bug.

      Paul

       
    • Phillbo
      Phillbo
      2005-02-13

      Awesome, thanks! worked like a charm!
      If anyone else is using this hardware, the correct order of the modules is "scsi_mod sg sd_mod megaraid"
      Thanks again Paul

      Phill