#250 Fix of mingw-w64 warnings concering out of boundary array access

Unstable
closed-accepted
nobody
None
5
2014-05-19
2014-05-17
f0rt
No

The mingw-w64 compiler based on the version 4.9.0 of the GNU compiler (gcc) requires syntactial sugar to correctly detect access of an array within its bounds. The patch fixes the "array subscript is above array bounds" compiler warnings

1 Attachments

Discussion

  • Amir Szekely
    Amir Szekely
    2014-05-18

    Looks good. Feel free to commit it.

     
  • f0rt
    f0rt
    2014-05-18

    Thanks for your review. I committed the patch (svn revision: r6484).

     
  • Amir Szekely
    Amir Szekely
    2014-05-19

    • status: open --> closed-accepted