Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Could not fetch information from the server

Help
mit
2007-03-29
2013-01-10
  • mit
    mit
    2007-03-29

    hello all
    I set up a windows 2000 server with some application services running. NSClient0.2.7 is installed and service starts correctly. I also did some tests with the command nsclient++ /test and worked fine.

    I put a nagios box to pull the performance information, e.g. cpuload, memory etc. However, when i try the test command in nagios /check_nt -H 222.222.222.222 -p 1248 -s password -v UPTIME, it returned the message: Could not fetch information from the server.

      I have successfully installed the same nsclient++ on an exchange windows 2003 server. And nagios just work perfect to be able to get all the performance information.

    my network set up is: windows 2000 server -> linux firewall -> nagios box

    the tcpdump information on nagios is
    [root@hostnagios plugins]# tcpdump tcp port 1248
    tcpdump: listening on eth0
    11:32:49.707871 hostnagios.57903 > fax.service.com.1248: S 4046572991:4046572991(0) win 5840 <mss 1460,sackOK,timestamp 50061829 0,nop,wscale 0> (DF)
    11:32:49.708370 fax.service.com.1248 > hostnagios.57903: S 4281372421:4281372421(0) ack 4046572992 win 17520 <mss 1460,nop,wscale 0,nop,nop,timestamp 0 0,nop,nop,sackOK> (DF)
    11:32:49.708397 hostnagios.57903 > fax.service.com.1248: . ack 1 win 5840 <nop,nop,timestamp 50061829 0> (DF)
    11:32:49.708446 hostnagios.57903 > fax.service.com.1248: P 1:18(17) ack 1 win 5840 <nop,nop,timestamp 50061829 0> (DF)
    11:32:49.818051 fax.service.com.1248 > hostnagios.57903: R 4281372422:4281372422(0) win 0 (DF)

    Thanks for the help~

     
    • mit
      mit
      2007-03-29

      problem resolved.

      cause: firewall was not allowed by nsclient++
      solution: add to hosts allowed

      I disable the allowed hosts option by default and i guessed nsclient++ used 192.168.xxx.xxx as default.

       
    • Jun
      Jun
      2007-08-16

      Hi,

      I also have this problem. I have allowed the port 1248 to go thru the firewall but to no avail. I did not get your solution, can you explain it to me please? :D