The specified module could not be found.

Anonymous
2011-12-14
2013-05-21

  • Anonymous
    2011-12-14

    Trying to setup DBGP Plugin and it seems to connect to Notepad++ but I cannot figure out what this error is.

    Whenever I turn the plug-in ON and set the session in the browser N++ comes up with a popup and an error that simply states: "The specified module could not be found."

    Tried a clean install of latest Notepad++ 5.9.6.2 UNICODE no plugins (minimalist) and added the latest dbgpPlugin v12 beta.

    Tried to follow this tutorial: http://amiworks.co.in/talk/debugging-php-using-xdebug-and-notepad-part-i/

    My config settings:

    DBGp:
    ✓ Bypass all mapping
    Misc - tried all combinations of on|off
    Remote Server IP: 127.0.0.1
    IDE KEY: xdebug
    Remote Path: c:\wamp\www
    Local Path: c:\wamp\www

    My Environment:
    Server is setup on local machine. Windows Vista Home Premium SP 2

    php.ini xdebug settings:

    [xdebug]
    zend_extension = c:\wamp\bin\php\php5.3.5\ext\php_xdebug-2.1.2-5.3-vc6.dll
    xdebug.profiler_output_dir = "c:/wamp/tmp/xdebug"
    xdebug.profiler_output_name = "cachegrind.out.%p"
    xdebug.profiler_enable = 0
    xdebug.profiler_append=0
    xdebug.extended_info=1
    xdebug.remote_enable=1
    xdebug.remote_handler=dbgp
    xdebug.remote_mode=req
    xdebug.remote_host=127.0.0.1
    xdebug.remote_port=9000
    xdebug.idekey=xdebug
    xdebug.remote_log="c:/wamp/tmp/xdebug/xdebug_remot.log"
    xdebug.show_exception_trace=0
    xdebug.show_local_vars=9
    xdebug.show_mem_delta=0
    xdebug.trace_format=0
    

    I have verified Xdebug is working w/ phpinfo and testing various methods.
    Also as a side note, I tested XDebugClient and it is working.

    Any help and/or clues would be MUCH appreciated. Thank you.

    Let me know if there is any additional info that would help.