Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

How to stop into the source

2008-05-27
2013-05-21
  • Ivo Stoykov
    Ivo Stoykov
    2008-05-27

    Hello,

    Sorry for dull question, but how to stop on particular line in the source.

    Xdebug is set and running (seen in phpinfo)
    I call following URL: http://127.0.0.1/test.php?XDEBUG_SESSION_START=test&q=1
    Np++ flashes on the taskbar and debugger opens, but does not stop on breakpoint (line 2).

    in config I've set
    Remote Server IP   IDE KEY   Remote Path                Local Path
    127.0.0.1          {empty}   E:\xampp\htdocs\test.php   E:\xampp\htdocs\test.php

    Here is console contents:

    Accept: 127.0.0.1
    Recv: <?xml version="1.0" encoding="iso-8859-1"?>
    <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///E:/xampp/htdocs/test.php" language="PHP" protocol_version="1.0" appid="3888" idekey="ivo"><engine version="2.0.3"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2008 by Derick Rethans]]></copyright></init>
    Send: feature_set -i 1 -n max_depth -v 3
    Send: feature_set -i 2 -n max_children -v 15
    Send: breakpoint_list -i 3
    Send: step_into -i 4
    ----
    Recv: <?xml version="1.0" encoding="iso-8859-1"?>
    <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="1" feature="max_depth" success="1"></response>
    Recv: <?xml version="1.0" encoding="iso-8859-1"?>
    <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="2" feature="max_children" success="1"></response>
    Recv: <?xml version="1.0" encoding="iso-8859-1"?>
    <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_list" transaction_id="3"></response>
    Recv: <?xml version="1.0" encoding="iso-8859-1"?>
    <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="step_into" transaction_id="4" status="stopping" reason="ok"></response>
    Send: run -i 5
    ----
    Disconnect: 127.0.0.1

     
    • Damjan Cvetko
      Damjan Cvetko
      2008-05-28

      Hi.
      If it connects, it's a good start. If it doesn't stop on a breakpoint usually one of these two are the problem:
      1. Xdebug is not loaded as ZEND extension (zend_extension=c:\full_path\php_xdebug...) - there should be a warning in phpinfo
      2. There is no code on that particular line (make sure there is something simple on that line like  echo "test\n";)

      Best regards.

       
    • Ivo Stoykov
      Ivo Stoykov
      2008-05-28

      Hi. And thank you for the fast replay.

      in phpinfo i've got no warnings...
      Np++ is v 4.9.2. Plugin is last stable

      Following is information I hope will be useful... Sorry for the length ;-(

      URL i open is: http://127.0.0.1/test.php?XDEBUG_SESSION_START=test&q=1

      here is the PHP file:

      <?php
      $a = 'test';
      $b = $_GET['q']; // <- here is the breakpoint - line 2
      echo "This is test line 1.\n<br>";
      echo "\n<br>This is the value of variable a - $a<br>\n";
      echo "\n<br>This is the value of variable b - $b<br>\n";
      print "This file is for testing Xdebug and Notepad++\n";
      echo '<br><hr>'."\n";

      phpinfo();
      ?>

      -----------------------
      today I've got additionally
      "Unable to map filename:  E:\xampp\htdocs\test.php (ip: 127.0.0.1 idekey: test) unix: False"

      Settings are still as before

      -----------------------
      settings in php.ini

      [XDebug]
      ;; Only Zend OR (!) XDebug
      zend_extension_ts="E:\xampp\php\ext\php_xdebug.dll"
      xdebug.remote_enable=true
      xdebug.remote_host=127.0.0.1
      xdebug.remote_port=9000
      xdebug.remote_handler=dbgp
      xdebug.profiler_enable=1
      xdebug.profiler_output_dir="E:\xampp\tmp"
      xdebug.remote_mode=req
      xdebug.remote_autostart=1

      -----------------------
      phpinfo settings are:

      report_zend_debug On
      zend.ze1_compatibility_mode Off

      ....

      -----------------------
      for Xdebug in phpinfo

      xdebug
      xdebug support enabled
      Version  2.0.3 

      Supported protocols Revision
      DBGp - Common DeBuGger Protocol  $Revision: 1.125.2.4 $ 
      GDB - GNU Debugger protocol  $Revision: 1.87 $ 
      PHP3 - PHP 3 Debugger protocol  $Revision: 1.22 $ 

      Directive Local Value Master Value
      xdebug.auto_trace Off Off
      xdebug.collect_includes On On
      xdebug.collect_params 0 0
      xdebug.collect_return Off Off
      xdebug.collect_vars Off Off
      xdebug.default_enable On On
      xdebug.dump.COOKIE no value no value
      xdebug.dump.ENV no value no value
      xdebug.dump.FILES no value no value
      xdebug.dump.GET no value no value
      xdebug.dump.POST no value no value
      xdebug.dump.REQUEST no value no value
      xdebug.dump.SERVER no value no value
      xdebug.dump.SESSION no value no value
      xdebug.dump_globals On On
      xdebug.dump_once On On
      xdebug.dump_undefined Off Off
      xdebug.extended_info On On
      xdebug.idekey ivo no value
      xdebug.manual_url http://www.php.net http://www.php.net
      xdebug.max_nesting_level 100 100
      xdebug.profiler_aggregate Off Off
      xdebug.profiler_append Off Off
      xdebug.profiler_enable On On
      xdebug.profiler_enable_trigger Off Off
      xdebug.profiler_output_dir E:\xampp\tmp E:\xampp\tmp
      xdebug.profiler_output_name cachegrind.out.%p cachegrind.out.%p
      xdebug.remote_autostart On On
      xdebug.remote_enable On On
      xdebug.remote_handler dbgp dbgp
      xdebug.remote_host 127.0.0.1 127.0.0.1
      xdebug.remote_log no value no value
      xdebug.remote_mode req req
      xdebug.remote_port 9000 9000
      xdebug.show_exception_trace Off Off
      xdebug.show_local_vars Off Off
      xdebug.show_mem_delta Off Off
      xdebug.trace_format 0 0
      xdebug.trace_options 0 0
      xdebug.trace_output_dir /tmp /tmp
      xdebug.trace_output_name trace.%c trace.%c
      xdebug.var_display_max_children 128 128
      xdebug.var_display_max_data 512 512
      xdebug.var_display_max_depth 3 3

       
      • Damjan Cvetko
        Damjan Cvetko
        2008-05-28

        Hi again.

        Ok, first, I didn't ask the obvious. How did you set the breakpoint? Yellow mark is Notepad bookmark, red mark is a breakpoint. Set it by leaving the cursor on the line you want it and then a) press the red button b) use the menu (ctrl-f9 shortcut) or c) ctrl+left mouse click on the left margin, where the yellow mark usually appears (if you don't have a very recent NPP version, the bookmark will also appear.
        Check the breakpoints child window (should be on the right side) to see if the breakpoint is set. Try again and paste the debug output if it still doesn't work.

        I'm sorry to give such a basic instruction, but I couldn't see the plugin sending a breakpoint information to the server in your last post (I didn't look well enough) and there was no debug with this post.

        It's strange that you would get a map error if it worked for you the first time.
        I'll know more when I see the debug output..

        Oh, another suggestion. Theres an option to "break at first line...". This could help you see if at least some things work...

        Best regards.
        -Zobo

         
    • Ivo Stoykov
      Ivo Stoykov
      2008-05-28

      Thank you for the 'set by step' explanations. They are always very useful especially when one is completely stuck.

      Well about breakpoints I've set them by each of the way you've suggested.
      I see red dot on the left margin in NP and in Breakpoints debug window (mine appear on the left but I can dock it elsewhere)

      in Breakpoints window I have:
      col 1 - red dot;
      col 2 - Line (under Type);
      col 3 - E:\xampp\htdocs\test.php:2 (under Breakpoint data) and
      col 4 - 0 (under Hits)

      Raw DBGP is empty.

      Mapping is the same

      In setup I have checked
      break at first line
      refresh local context...
      refresh global context...

      In MSIE 6 or Firefox (last stable) I enter: http://127.0.0.1/test.php?XDEBUG_SESSION_START=test&q=1
      and NP flashed immediately

      result:

      unable to map... (same)

      red dot in Breakpoints disappeared (but is visible in NP)
      Above Header rows I see "Disconnected"

      I do not have neither IIS installed - using XAMMP 1.1.1.2 nor any other IDE compilers/debuggers

      Raw DBGP now reads:

      Accept: 127.0.0.1
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///E:/xampp/htdocs/test.php" language="PHP" protocol_version="1.0" appid="3412" idekey="test"><engine version="2.0.3"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2008 by Derick Rethans]]></copyright></init>
      Send: source -i 1 -f file:///E:/xampp/htdocs/test.php
      Send: feature_set -i 2 -n max_depth -v 3
      Send: feature_set -i 3 -n max_children -v 15
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="source" transaction_id="1" encoding="base64"><![CDATA[PD9waHANCiRhID0gJ3Rlc3QnOw0KJGIgPSAkX0dFVFsncSddOw0KZWNobyAiVGhpcyBpcyB0ZXN0IGxpbmUgMS5cbjxicj4iOw0KZWNobyAiXG48YnI+VGhpcyBpcyB0aGUgdmFsdWUgb2YgdmFyaWFibGUgYSAtICRhPGJyPlxuIjsNCmVjaG8gIlxuPGJyPlRoaXMgaXMgdGhlIHZhbHVlIG9mIHZhcmlhYmxlIGIgLSAkYjxicj5cbiI7DQpwcmludCAiVGhpcyBmaWxlIGlzIGZvciB0ZXN0aW5nIFhkZWJ1ZyBhbmQgTm90ZXBhZCsrXG4iOw0KZWNobyAnPGJyPjxocj4nLiJcbiI7DQoNCnBocGluZm8oKTsNCj8+]]></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="2" feature="max_depth" success="1"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="3" feature="max_children" success="1"></response>
      ----
      Send: breakpoint_list -i 4
      Send: step_into -i 5
      ----
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_list" transaction_id="4"></response>
      ----
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="step_into" transaction_id="5" status="stopping" reason="ok"></response>
      Send: run -i 6
      ----
      Disconnect: 127.0.0.1

       
    • Damjan Cvetko
      Damjan Cvetko
      2008-05-29

      Hi again.

      You are having some weird problems here.
      The error you are getting - Unable to map... - happens when Xdebug connects to Notepad and Notepad tries to send its breakpoints to the server. In order to send them, each Local filename must be mapped to a Remote filename. (Mind, I mostly work with linux servers, so in a local Windows setup, this doesn't make a lot of sense). If it is unable to map a local file (E:\xampp\htdocs\test.php) it will throw an error and will not send that breakpoint (no use to confuse the server with useless data). The "invalid" breakpoint will be removed - I will want to work on removing the red dot also.

      Anyway. Even if all mapping fails (as it does in this case - for no obvious reason) the plugin will still get the file that is debugged via the SOURCE command. This happens correctly. (You can check, if you take the long CDATA and wrap it into var_dump(base64_decode.... ). This file should be stored in some temporary dir (in my case C:\Documents and....\Local..\Temp\dbgp_file%3a%2f%2f%2fD%3a%2fxxx%2fphp%2ftest1.php) - If you want to play around with this, you could set the TMP environment variable. Try to search your drive for *test.php file to confirm it's really there. (Perhaps we are having some file storing problems.)

      Anyway.
      Try the next things:
      1. Change mapping to    127.0.0.1 {empty} E:\&nbsp;  E:\&nbsp;  - check that no extra spaces are present around E:\ 2. Try not to set any breakpoints, the "break at first line" should still give you something
      3. Try to remove all mappings and again no breakpoints

      I tested things, they work fine for me in all cases... This is some problem you are having here, but we'll get it eventually :)

      Oh, another dummy note just in case: If you see a green arrow on the margin, that's good. Press "step into" to move from line to line.

      Best regards
      -Zobo

       
    • Ivo Stoykov
      Ivo Stoykov
      2008-05-29

      Hello

      Unfortunately none of the three points does not work. Unable to map box disappeared though.

      I run with full admin rightes and firewall switched off in attempt to avoid all system restrictions.
      I've also checked on/off all check boxes in config

      The only effect is lack of map dialog...

      I'll check the XAMPP setup and file locations as a last attempt. There should be some config problem I miss ;-((

       
    • Ivo Stoykov
      Ivo Stoykov
      2008-05-29

      Well - there are good new and bad news - hope there is some key(s) for help solving this issue

      Good news is that I've make a step on
      Bad one - direction is unknown ;-)

      I downloaded latest XAMPP 1.6.6a in an attempt to use debugger. Also changed querystring order.
      Break at first line and
      Use SOURCE...
      are checked

      And I've got another message:

      Windows socket error: An established connection was aborted by by the software in your host machine (10053), on API 'rcv'

      Raw DBGP

      Accept: 127.0.0.1
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///E:/xampp/htdocs/test.php" language="PHP" protocol_version="1.0" appid="2216" idekey="ivo"><engine version="2.0.3"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2008 by Derick Rethans]]></copyright></init>
      Send: source -i 1 -f file:///E:/xampp/htdocs/test.php
      Send: feature_set -i 2 -n max_depth -v 3
      Send: feature_set -i 3 -n max_children -v 15
      Send: breakpoint_set -i 4 -t line -f file://e:/xampp/htdocs/test.php -n 3 -s enabled -h 0 -o >=
      Send: breakpoint_list -i 5
      Send: step_into -i 6
      ----
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="source" transaction_id="1" encoding="base64"><![CDATA[PD9waHANCiRhID0gJ3Rlc3QnOw0KJGIgPSAkX0dFVFsncSddOw0KZWNobyAiVGhpcyBpcyB0ZXN0IGxpbmUgMS5cbjxicj4iOw0KZWNobyAiXG48YnI+VGhpcyBpcyB0aGUgdmFsdWUgb2YgdmFyaWFibGUgYSAtICRhPGJyPlxuIjsNCmVjaG8gIlxuPGJyPlRoaXMgaXMgdGhlIHZhbHVlIG9mIHZhcmlhYmxlIGIgLSAkYjxicj5cbiI7DQpwcmludCAiVGhpcyBmaWxlIGlzIGZvciB0ZXN0aW5nIFhkZWJ1ZyBhbmQgTm90ZXBhZCsrXG4iOw0KZWNobyAnPGJyPjxocj4nLiJcbiI7DQoNCnBocGluZm8oKTsNCj8+]]></response>
      ----
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="2" feature="max_depth" success="1"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="3" feature="max_children" success="1"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="4" state="enabled" id="22160001"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_list" transaction_id="5"><breakpoint type="line" filename="file:///e:/xampp/htdocs/test.php" lineno="3" state="enabled" hit_count="0" hit_condition="&gt;=" hit_value="0" id="22160001"></breakpoint></response>
      Send: source -i 7 -f file:///e:/xampp/htdocs/test.php
      ----
      Disconnect: 127.0.0.1

       
    • Ivo Stoykov
      Ivo Stoykov
      2008-05-29

      Sorry for continuous post, but I really hope that information supplied could help solving that boaring problem.

      Unable to map filename: D:\Temp\dbgo_file%3a%2f%2f%2f%3a%2fxampp%2fhtdocs%2ftest.php (ip: 127.0.0.1 idekey: ivo) unix: 1

      In config I've checked
      x Break at first line and
      x Use SOURCE...
      x Start with closed socket

      D:\Temp is my temp folder set in windows. Path mapping is 127... {empty} E:\ E:\

      --------------------------------------------

      Another attempt

      mapping is 127... {empty} E:\ E:\

      config I've checked
      x Break at first line and
      x Use SOURCE...

      break point on line 2

      Result - messagebox saying
      Element does not contain a single text node

       
    • Ivo Stoykov
      Ivo Stoykov
      2008-05-29

      Final post - really - forgot raw DBGP

      Accept: 127.0.0.1
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///E:/xampp/htdocs/test.php" language="PHP" protocol_version="1.0" appid="2216" idekey="ivo"><engine version="2.0.3"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2008 by Derick Rethans]]></copyright></init>
      Send: source -i 1 -f file:///E:/xampp/htdocs/test.php
      Send: feature_set -i 2 -n max_depth -v 3
      Send: feature_set -i 3 -n max_children -v 15
      Send: breakpoint_set -i 4 -t line -f file://e:/xampp/htdocs/test.php -n 3 -s enabled -h 0 -o >=
      Send: breakpoint_list -i 5
      Send: step_into -i 6
      ----
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="source" transaction_id="1" encoding="base64"><![CDATA[PD9waHANCiRhID0gJ3Rlc3QnOw0KJGIgPSAkX0dFVFsncSddOw0KZWNobyAiVGhpcyBpcyB0ZXN0IGxpbmUgMS5cbjxicj4iOw0KZWNobyAiXG48YnI+VGhpcyBpcyB0aGUgdmFsdWUgb2YgdmFyaWFibGUgYSAtICRhPGJyPlxuIjsNCmVjaG8gIlxuPGJyPlRoaXMgaXMgdGhlIHZhbHVlIG9mIHZhcmlhYmxlIGIgLSAkYjxicj5cbiI7DQpwcmludCAiVGhpcyBmaWxlIGlzIGZvciB0ZXN0aW5nIFhkZWJ1ZyBhbmQgTm90ZXBhZCsrXG4iOw0KZWNobyAnPGJyPjxocj4nLiJcbiI7DQoNCnBocGluZm8oKTsNCj8+]]></response>
      ----
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="2" feature="max_depth" success="1"></response>
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="3" feature="max_children" success="1"></response>
      ----
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_set" transaction_id="4" state="enabled" id="22160003"></response>
      ----
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="breakpoint_list" transaction_id="5"><breakpoint type="line" filename="file:///e:/xampp/htdocs/test.php" lineno="3" state="enabled" hit_count="0" hit_condition="&gt;=" hit_value="0" id="22160003"></breakpoint></response>
      Send: source -i 7 -f file:///e:/xampp/htdocs/test.php
      ----
      Recv: <?xml version="1.0" encoding="iso-8859-1"?>
      <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="step_into" transaction_id="6" status="stopping" reason="ok"></response>
      Send: run -i 8
      ----
      Disconnect: 127.0.0.1

       
    • Ivo Stoykov
      Ivo Stoykov
      2008-05-29

      After many, many attempts and config games I wisely decided to wait next version.

      Just want to say that meanwhile I found and tried xdebugclient (http://code.google.com/p/xdebugclient/)
      It runs and catch debug session just fine (still has much more cons than pros but runs!)

      XAMPP & php, etc settings are must the same.
      Test file is the same.

      and it runs into code.

      Perhaps there is something in my system, NP, DBGP settings wrong.
      Unfortunately I cannot catch it ;-((

      Waiting for next release.

       
      • Damjan Cvetko
        Damjan Cvetko
        2008-05-30

        Hi Ivo.

        First, thank you for your determination to make this work. I'll try to set up the same environment you described here to see if theres something else going wrong. I'll give you some good news though:
        - Mapping works, I can see a breakpiont being set in the raw log (and returned by the server).
        - The only thing that should be done is to uncheck "Use SOURCE" config.

        I see that the configuration causes a lot of confusion, especially for people running on windows. I'll make a release that should make setting up the plugin easier.

        Until then, thank you again for your efforts.
        -Zobo

         
    • Ivo Stoykov
      Ivo Stoykov
      2008-05-30

      Thank you,

      Waiting for next release. Meanwhile I downloaded the source and will take a look inside in hope to understand what to do.

      All the best
      Ivo

       
    • Kerfred
      Kerfred
      2009-01-19

      I have had the same problem.
      And I just found the solution.

      php_xdebug should not be loaded as an extension in PHP.ini.
      You should remove the line : extension=php_xdebug.dll

      php_xdebug should only be loaded as a ZEND extension with zend_extension_ts=full_path_to_php_xdebug.dll

      Hope this helps.

      Regards,
      Kerfred
      --

       
    • Silvio Macedo
      Silvio Macedo
      2009-02-07

      Hi guys,

      Thank you Zobo for the plugin.

      Thank you Ivo for being so thorough

      Thank you Kerfred for solving the problem.

      I was having the same problem as Ivo and Kerfred's solution was the answer.

      I even had some  xdebug_break(); in the code, and they would stop the flow alright.. but no breakpoints or step into whatsoever...

      So - let me add a few keywords for googlers:

      bgdpp plugin xdebug cannot step into code notepad++ breakpoint doesn't work xampp php.ini