Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#58 Notion freezes when using selenium testing

open
nobody
None
5
2014-04-02
2013-01-29
Drake Douay
No

I am running notion on Ubuntu 12.10, and Firefox 18.0.1. I use tmux, bash and xterm in case it matters. The bug occurs I run selenium-server 2.29.0, and run acceptance testing. After the testing is complete Notion no longer works. Everything looks normal except none of my frames are highlighted, and I cannot find any combination of keystrokes to active any of the windows. Also F12 no longer works so I cannot, logout or restart notion.

The testing I am running is Yii's default acceptance tests, specifically the file in protected/tests/functional/SiteTest.php. I use phpunit to run it.

In order to regain control I need to press CTRL-ALT-F1 and pkill firefox. After I do that one of my frames becomes active and everything returns to normal. If I instead pkill java, then I will need to close notion to regain control. pkilling firefox when java is not running will have no effect.

Please let me know if there is any of details you need.

Discussion

  • Arnout Engelen
    Arnout Engelen
    2013-01-29

    Interesting! This sounds like something I sometimes run into but have been unable to reliably reproduce.

    To verify this is the same thing, can you verify:
    * You can still move the mouse pointer around
    * The pointer still changes shape properly when it hovers different kinds of windows
    * When you change the windows (e.g., hit f2 to fill a frame that previously held Firefox with an xterm), the mouse pointer suggests indeed firefox was replaced by an xterm (the mouse pointer becomes a caret instead of an arrow), but firefox is still what's visible on the screen

    Are you using the nouveau display drivers?

     
  • Drake Douay
    Drake Douay
    2013-01-30

    I can still move the mouse, and the pointer changes shape. It appears the problem is a background process is now active and it doesn't release control.

    F2 does not work.

    Also for some reason the problem is not being reporduced as consistently as before. Now I need to run the test multiple times before it freezes. I am going to reboot and see if I can make this bug more reliable :-)

    What you are talking about sounds very similiar, but I suspect they may be different.

     
  • Drake Douay
    Drake Douay
    2013-01-30

    I am not sure which display drivers I am using. Here is what lshw says.

    $ sudo lshw -c video
    *-display
    description: VGA compatible controller
    product: 2nd Generation Core Processor Family Integrated Graphics Control
    ler
    vendor: Intel Corporation
    physical id: 2
    bus info: pci@0000:00:02.0
    version: 09
    width: 64 bits
    clock: 33MHz
    capabilities: msi pm vga_controller bus_master cap_list rom
    configuration: driver=i915 latency=0
    resources: irq:42 memory:fe000000-fe3fffff memory:d0000000-dfffffff iopor
    t:f000(size=64)

     
  • Arnout Engelen
    Arnout Engelen
    2014-04-02

    I haven't seen this problem for a while. Are you still experiencing it?