Displaying multiple languages in English UI

2007-01-22
2012-11-14
  • I have a lot of localized xml files that i need to view in notepad++. Most of those I look at appear correctly, except for Korean. My other applications and files do display in korean (dreamweaver, IE, etc.), but not notepad++. Can anyone tell me why, and/or what I should do to correct this problem?  Thanks - Anna

     
    • I need to know how to display Japanese?

      Can you display this Anna? If so can you tell me how?

      Thanks,

      Dave

       
    • [poster: Liberty Miller]
      [date: 2007-01-23 ]

      I'd also like to chime in with a request for Japanese encoding support (in particular, EUC-JP).

      Unicode is great, and works for many things, but it doesn't help if the file you are trying to open was encoded with a different language in the first place. (For example, doing a "View Source" with Notepad ++ set as the default html viewer when the page is Japanese, Korean, etc.)

      = How to Convert Existing Text Files from Asian languages to UTF-8 =

      For Dave, and anyone else interested, here's a workaround for Windows XP with Asian language support enabled:

      1. Open the document you are interested in in Notepad (the oldy but goody);
      2. Use "Save as..." and select "Save as type:" [Text] ; "Encoding:" [UTF-8] ;
      3. Now you should be able to open the file with Notepad++ (because, hopefully,
      you've converted the file from X encoding to UTF-8....)

      Hope that helps,
      Liberty

      ----
      Reference for Notepad++ version 3.8:
      format = 0/1/2 -> win/unix/mac
      encoding = 0/1/2/3/4/5 -> ANSI / UCS2Big / UCS2small / UTF8 / UTF8-BOM*

      (UTF minus BOM, i.e. without BOM)