CR LF at statr of line, BAD at end after editing on large(ish) textfile

  • bert_HH

    Hi all,
    since I couldn't find anything on this behaviour with the search I thought I might ask. I've been using npp for about ten months to do textfile reformatting (regex replace, column edit etc.) without a problem.

    In the last few days however I had a few issues with this: After doing some operation the line breaks don't look the way they should (BAD icon at the end, CR and LF at start of line) and some lines get shifted and or recombined seemingly at random. Here's a screenshot to clarify the issue of broken line breaks:

    It does not always happen and is apparently independent of operation (happened with regex replace, regular replace, column edit). I tried to reinstall npp, but to no avail.
    Anyone got any idea what might be causing this and how I can prevent it?

  • Pat a Mat
    Pat a Mat

    I saw the same behaviour last week. I believe this occurs when the new 'session snapshot and periodic backup'-feature saves the current file between a exhausted 'search & replace' operation on very large files.

    Please trying disable the 'session snapshot and periodic backup'-feature or set it to a long time (let's say 5 minutes) and perform the replace operation again.

    It would be nice, if you could report your result for possible fixing this bug.

  • bert_HH

    OK, thanks for the answer! I set it to 60 seconds now, we'll see if it helps. I'll report after a few replacements/deletions.

  • bert_HH

    So, behaviour seems to be back to normal. But since I also deinstalled some plugins I no longer use, whether the problem had to do with plugins or snapshot is not really clear.
    However, since Pat a Mat has solved his problems the way he described I think the solution is viable and may justify a bugtracking session. If I get around to it I'll try it with shorter backup intervalls again, in the meantime Thanks a lot for the help!

    Edit: Well, I celebrated early. Did a column deletion on 130,000 lines, same error as before. At least we know it were not the plugins. :-S I'll increase the snapshot time some more and see if that helps.

    Last edit: bert_HH 2014-07-08
  • Kevin F
    Kevin F

    Had the same issue,, garbled and broken files after replace all operations.
    SOLVED by DISABLING "Enable session snapshot and periodic backup"
    I noticed that increasing the seconds only creates a russian roulette situation.

    Shame, I liked the backup feature but at the expense of file integrity?
    I began using notepad++ because other editors for windows often make arbitrary changes to files or can not handle large files. Is there a bug report for this issue?

    Last edit: Kevin F 2014-08-29
  • Donovan W
    Donovan W

    Much like everyone else, I had the same problem was about to give up using NPP and switching to something else before I found this thread.

    Disabling "Enable session snapshot and periodic backup" did the trick.