Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

inactive tab's color

2. Help
2005-04-22
2013-07-14
  • The color of the inactive tabs are gray, so are the texts on them. It is very hard for me to read and pick the right tab. Can I change the color?

     
    • Hello,

      In Notepad++ there's some tab options in Settings > Preferences > Global

      regards,
      ranMa

       
    • Don HO
      Don HO
      2005-04-23

      you can disable it in the menu "View".

      Don

       
  • Moe Coder
    Moe Coder
    2013-06-29

    Please RESTORE the color preference adjustment for 'inactive tab' in
    Style Configurator > Global Styles > Inactive Tabs.
    This used to be in the settings up until the feature changed to be a checkbox in
    Preferences > General > Tab Bar > "Darken inactive tabs".
    There simply is not a satisfactory contrast between the text and the background.
    This used to be a user setting, and was REMOVED in favor of the checkbox.
    The checkbox is fine and can stay, please re-add the color preference so that contrast can be improved.
    THANK YOU.

     
  • THEVENOT Guy
    THEVENOT Guy
    2013-06-29

    Hi Don, Moe Coder, and All,

    I totally agree with that request. It's really not easy to read the name of files on inactive tabs :(

    Indeed, the four styles below :

    • Active tab focused indicator
    • Active tab unfocused indicator
    • Active tab text
    • Inactive tabs

    are not displayed, any more, in Settings\Style Configurator... for the pseudo-language Global Settings, after the last style Tags attribute.

    And, if you try to manually change the colour of the item fgColor, in the style Inactive tabs, at the end of the file Stylers.xml, with, for example, Wordpad editor, it doesn't work too !

    Notice that, with my last ANSI version of N++ ( 5.9.8 ), it works fine : you can even
    test different colours for foreground text of inactive tabs, without validate the Style Configurator
    !!!

    So, Don, would it be possible to consider, again, these parameters in the Style Configurator, like in older versions ?

    If you don't want to go back to that old behaviour, perhaps it will be possible to set the foreground colour of inactive tabs to black colour ( #000000 ), instead of the grey colour #808080.

    Many thanks for our eyes :)

    Cheers,

    guy038

     
    Last edit: THEVENOT Guy 2013-06-29
  • cchris
    cchris
    2013-06-30

    Indeed the styles have disappeared, which is a definite regression.

    However, I still have some color hints when Settings -> Preferences , Tab bar, Color inactive tabs is enabled.

    @Don: may I remind you that I have a patch concerning active tab colours; perhaps is it time to consider integrating it.

    CChris

     
  • pinchy
    pinchy
    2013-07-05

    I have been trying to fix this for a while now. Its got me absolutely stumped.
    I use the "deep black" style and the 4 tab settings are there but you cant save them. You can change them but as soon as you save&close it reverts back to the old setting. you have to manually go in the file and change it.

    chris: does your patch address this issue?

     
  • cchris
    cchris
    2013-07-06

    The patch provides separate foreground and background for both active and inactive tabs. It should still work, but was done against a slightly old version.

    If your changes don't stick, then the patch won't help: Windows is preventing you from saving configuration files out of safety. Please ake total ownership of the folder where stylers.xml is. Alternately, install elsewhere than Program Files - that's the simplest I think.

    CChris

     
  • pinchy
    pinchy
    2013-07-06

    Its not a file permissions issue because it will save all the other changes up those last 4 or 5 tab settings. Theres something really strange goin on in the code since it seems to pull back the old setting for those tab settings. I thought it was some indexing issue but doesnt seem to be the case.

    Ive spent too much time debugging it. its probably something simple im missing.

     
  • Don HO
    Don HO
    2013-07-08

    CChris,

    Please provide the link of your patch.
    I'll integrate this feature.

    Don