Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Help - xhtml files show like this now: NUL NUL NUL NUL ÷<øʳcÒ{è„xà‚µê¶U*S

2. Help
coolhotice
2014-03-23
2014-03-30
  • coolhotice
    coolhotice
    2014-03-23

    Oh boy, I ask what is going on and how do I fix?

    When I open an xhtml file the code is lots of NUL NUL NUL NUL
    As code shown below - pasted the code but the NUL do not show up after paste.
    For example it goes NUL4NUL2NUL4NUL.....

     8   D(4:ö‡çÔÁ4Ïé   ( r Ð @·œñ€U®^ÝÔŸï)=*uZü!4 e 1 0 f 8 d a - 8 7 3 e - 4 2 4 2 - 8 d 5 0 - 8 3 9 8 4 d 1 3 f 7 a 6 M i

    Then this without any NUL just like this:
    „‚Dö˜tDHU@… P_¦4t ýÉHv÷xÝ4íÖNÓ‘:!5+ºmÀšÐpWFÓ¸tõ»½Údù7[˘™L$aYŸÛ9QÿáHž|ü‘÷<øʳcÒ{è„xà‚µê¶U*S [¢n bЂºÿ\QÍp‚z£ýÖ

    NOTE: Using the latest up date 6.5.5
    txt- files show fine.

    NOTE: was showing xhtml files fine before. Had a computer crash and had to do a Clickfree image install backup. Computer all back working fine. However all xhtml files are now all filled with NUL.

    When check to see how looks in browser the regular error message shows (guess written into code) if there is an error. It shows fine but says nothing to show or empty.

    This is how the print out to chome browser looks:

    This page contains the following errors:

    error on line 1 at column 1: Document is empty
    error on line 1 at column 1: Encoding error
    Below is a rendering of the page up to the first error.

    (it should show text and an image) But does understand what ever is on the page as code. When view source (chrome page only this shows
    ROBSNTFS

    In Firefox it shows this on the browser:
    XML Parsing Error: not well-formed Location: file:///C:/Users/nanuq/Pictures/Jim%20Dream%20Book/copytojason/B-Book/html/page03.xhtml Line Number 1, Column 1:

    and view source is this

    nothing will paste what is shown is
    ROBSNTFS? (? IS IN A DIAMOND BOX) ????????
    ?N?1??Y???TNN:8D(4:????
    .... and so on for ten lines.

    Using English.

    What should I do or change setting to read my xhtml files?

    Thank-you.

     
    Last edit: coolhotice 2014-03-23
  • cchris
    cchris
    2014-03-30

    What is the encoding shown on the status bar?
    My guess is that your files are encoded using UTF-8 or UCS-2LE. Try Characters->Encode to get the proper encoding, then Character->Convert to that encoding. EVerything should be fine thereafter.

    CChris