Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Vista Compatiblity

2. Help
2007-06-14
2012-11-14
1 2 > >> (Page 1 of 2)
  • Will the latest version of N++ function with all the new quirks of Windows Vista?

     
    • Where is the auto-update option?  I am not seeing it in version 4.8.
      http://img297.imageshack.us/my.php?image=npppreferencesru4.jpg

       
    • The lastest version of N++ works correctly on Windows Vista !

       
      • The lastest version doesn't work right on Vista 64 bit. it's missing the shell plugin for opening files with N++ by right clicking

         
        • I'm also seeing this on x64 vista.

           
      • Wen Hao Chuang
        Wen Hao Chuang
        2007-12-19

        I'm using the latest version on Vista 32bit but every time when I open up the N++ it will gave me a error message:

        CreateProcess:

        X The requested operation requires elevation.

        Anyone know why is that? Is it just me or it's a known bug in vista 32bit? Thanks!

         
        • I'm having the same "The requested operation requires elevation" error every time I try to open a .asp, .asa or other similar script files on Vista 32-bit.

          How can I fix this?

          Jason

           
          • This problem happens becase the updater GUP.exe is opened every time Notepad++ is launch. Windows Vista blocks some softwares that try to use de internet to check their updates.

            To "solve" this problem, go to Configurations, Preferences. In Preferences window, choose Other tab and disable the option "Enable Notpad++ auto-updater".

             
            • My problem is whenever I try to open the Preferences window, a Windows error message pops up saying  "Notepad++: a free (GNU) source code editor has stopped working", then NPP crashes.

              Under problem details, it shows

              Problem signature:
                Problem Event Name:    BEX
                Application Name:    notepad++.exe
                Application Version:    4.7.5.0
                Application Timestamp:    478bb384
                Fault Module Name:    notepad++.exe
                Fault Module Version:    4.7.5.0
                Fault Module Timestamp:    478bb384
                Exception Offset:    0003be44
                Exception Code:    c0000409
                Exception Data:    00000000
                OS Version:    6.0.6000.2.0.0.256.6
                Locale ID:    1033
                Additional Information 1:    cbb3
                Additional Information 2:    f7b6c02c8b2f909c2f9d023f569a9ca2
                Additional Information 3:    7092
                Additional Information 4:    772a48b02baf5ae9f52797bd72642eb0

               
              • I forgot to add that I have disabled UAC in Vista.

                 
            • Dennis Hohmann
              Dennis Hohmann
              2008-01-04

              Thanks man,
              that answer was really hard to find. Maybe it should be added to the offical FAQ!? ;-)

              Cheers,
              Dennis

               
        • so, can anyone tell us how to use it as a notepad replacement on Vista?  what do we replace and where?  Any edits to do in the Registry hive?  What's the deal?  Any clues?

           
          • The way i fixed the probem of elevation in vista is like this:

            under c:\program files\Notepad++\

            I set the compatibility to "run as windows xp with service pack 2" and all my problems were gone.

            Don't forget that the file that you place in c:\windows and c:\windows\system32 is just a launcher.

             
    • No, not for everyone, as it requires disabled UAC for me, even after several new installs!

       
    • On Vista 32bit Notepad++ sometimes stops responding and Vista automatically closes the program. It's very annoying but doesn't seem to happen too often (once a day with hardcore usage, I guess).

       
    • DV
      DV
      2007-12-19

      Men, please read this article. Of course, it's not a completely serious article, but it does show you what is Windows Vista vs. Windows XP.
      And then make your choice: do you really want Windows hasta la Vista on your PC or you want to say "hasta la Vista, baby" to this system.

      http://dotnet.org.za/codingsanity/archive/2007/12/14/review-windows-xp.aspx

       
    • Right.  For those who choose to suffer through the use of Vista... Anyone have a solution for using this app on a Vista box?  I was getting the error message above followed by another, '1002'.  At this point, Vista asks if I want to allow the operation every time I try to open a file.  I'm sure the answer is simple.  If anyone has the generosity to supply it that would be awesome.  Thanks.  -Eric

       
    • One more bit of information for anyone looking into this issue... The error goes away if one disables UAC.

      Not that I'm advocating disabling UAC.

       
      • I had the same issue after rebuilding my machine and installing the latest version of Notepad++.  However, I un-installed this version and re-installed an older one (v 3.9).  Version 3.9 didn't give me the error. 

         
        • Good plan. I just rolled back to the version I was  using on my previous Vista install (4.0.2) and all is well.

           
    • I love notepad++, but Vista is not going to go away. I recently purchased a laptop, so am stuck with Vista on it. On 32bit Vista notepad++ crashes each time I try to change the preferences. 

      What bothers me the most about Vista is not being able to manually set apps to ignore UAC. BTW UAC was the corrupt technology corporation in the Doom series...

       
    • Hey guys,

      Simply disable AutoUpdater as said before in this thread, and use the latest NPP version (4.7 is flagged for Vista compatibility).

      By disabling the AutoUpdater, you get away of the UAC prompt and the ProcessCreate followed by the 1022 error.

      Regards

       
    • Running Vista on a 64bit, I was not able to open the Preferences dialog without the program crashing. 

      Using Explorer, I changed the properties of the notepad++.exe file for Compatibility->Privilege Level to "Run this program as administrator".  This allowed me to open the Preferences and to then turn off the Preferences->MISC->"Enable Notepad++ auto-updater".

       
    • Aren Cambre
      Aren Cambre
      2008-02-16

      I have Notepad++ running on four Vista boxes.

      On 3 it runs fine, no UAC prompts at all.

      On the fourth one, at one point it did something that confused Vista, and to protect me, Vista put Notepad++ in some kind of "always do UAC mode".

      Like what is mentioned above, the "always do UAC mode" is only on gup.exe. But the question remains, why does it happen only on this computer and not the other 3 Vista machines?

       
    • Aren Cambre
      Aren Cambre
      2008-02-16

      I think I answered my own question.

      I found that NotePad++ was listed twice in keys under registry key:
      HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags

      Apparently when the Program Compatibility Assistant detects a problem with part of Notepad++, it forces it into a mode that requires UAC, and it does so by creating registry entries for the program somewhere in keys under the above key. Indeed, the Program Compatibility Wizard (not same as Assistance mentioned above) shows Notepad++ has a setting named ELEVATECREATEPROCESS.

      I'll bet there is some problem with Notepad++ or gup.exe that is causing this. I have other applications, like WinSCP, that are able to check online for newer versions and don't require UAC prompts.

       
1 2 > >> (Page 1 of 2)