Select to beginning/end of line?

2009-05-31
2012-11-13
  • Andy Fielding
    Andy Fielding
    2009-05-31

    Notepad++ is great, but it does one strange thing:

    I often use the standard keyboard shortcuts Shift+Home and Shift+End to select the text from the cursor to the beginning or end of the line.

    In Notepad++, these shortcuts select the text all the way to the beginning or end of the _paragraph_ instead.

    Is there any way to change this to the standard behavior?

    Thanks, ander

     
    • Andy Fielding
      Andy Fielding
      2009-06-04

      Woo-hoo! I finally got it to work. This is what you have to do:

      1. Set SCI_HOMEDISPLAYEXTEND to Shift+Home

      2. Set SCI_LINEENDDISPLAYEXTEND to Shift+End

      3. Be sure no other Scintilla commands are using those key combinations; if they are, set them to None.

      The official list of Scintilla commands (http://www.scintilla.org/CommandValues.html) was a big help with this.  ;?)

      Thanks for the great app, Cchris!

       
    • Andy Fielding
      Andy Fielding
      2009-05-31

      Oh, and how do you hide the toolbar? I never use it, and it's pretty distracting having to see it all the time. Thanks again!

       
    • cchris
      cchris
      2009-05-31

      1/ Go to Preferences -> Shortcut mapper -> Scintilla comands. Then try finding which command Shift+Home is bound to. For me, it is SCI_VCHOMEEXTEND, and I didn't tweak it. Shift+End is bound to SCI_LINEENDEXTEND. You may want to remap the SCI_PARAUPXTEND command, default is Ctrl+Shift+[. SCI_PARADOWNEXTEND is left as an exercise.

      2/ Preferences -> Settings -> General, choose the Hide option in the Tool bar frame.

      CChris

       
    • Andy Fielding
      Andy Fielding
      2009-06-01

      Thanks! A few notes:

      > 1/ Go to Preferences -> Shortcut mapper -> Scintilla comands...

      It's actually Settings > Shortcut Mapper > Scintilla commands (in case anyone else is looking for it).

      > Then try finding which command Shift+Home is bound to. For me, it is
      > SCI_VCHOMEEXTEND, and I didn't tweak it. Shift+End is bound to
      > SCI_LINEENDEXTEND. What you actually mean (again, in case anyone else wants
      > to do this) is:

      Change the shortcuts for SCI_VCHOMEEXTEND to Shift+Home, and SCI_LINEENDEXTEND to Shift+End

      > You may want to remap the SCI_PARAUPXTEND command, default is
      > Ctrl+Shift+[. SCI_PARADOWNEXTEND is left as an exercise.

      I tried these (using Ctrl+Shift+Up/Down), thinking they would let me select to the beginning/end of the paragraph. The 2nd one works fine---but the 1st one selects to the start of the current paragraph, _and_  the previous paragraph. (This is with 2 linebreaks between paragraphs.) Bug?

      Also, I found that when you change these shortcuts, you must click Apply before you click OK, or the change doesn't stay. That's irregular and counterintuitive. (The Apply button is usually to let the user apply visual changes to see how they look, for example, before closing the settings window.) I don't know who handles these kinds of things in the project, but I thought I'd mention it.

      > 2/ Preferences -> Settings -> General, choose the Hide option in the Tool bar
      > frame.

      Great. BTW, you really mean:

      Settings > Preferences > Global

      Thanks again for your help. (Wow, it'd be great if they'd get some 21st-century forum software on here too, wouldn't it?  :?)

       
    • Andy Fielding
      Andy Fielding
      2009-06-01

      Sorry about the crazy formatting on that message. Hope you can understand it.

      It's very hard to quote anything with this forum software... I assume a lot of people use it to discuss software issues, so I'm surprised it's so limited.

       
    • Andy Fielding
      Andy Fielding
      2009-06-01

      Sorry to bother you again... I've made the changes you described:

         SCI_VCHOMEEXTEND changed to Shift+Home

         SCI_LINEENDEXTEND changed to Shift+End

      ...and no other shortcuts are using those commands. Shift+Home works now (selects to beginning of line), but Shift+End still selects to the end of the paragraph. Any more ideas?

       
    • cchris
      cchris
      2009-06-02

      I'd check the SCI_PARADOWNEXTEND binding, and remap it to Ctrl+Shift+] if that's not how it is set.

      Oh, and thanks for mentioning the Settings and Preferences being switched. I switch between english and french a few times a day, so I guess that's where it got messed up.

      CChris