Cyrillic Character Input Problems

2005-08-15
2012-11-13
  • Don:

    I can not figure out why the Cyrillic does not display properly.  From what I see you have support for the Asian CJK family of languages.  I have the Windows Russian Cyrillic localizations enabled from the Control Panel.  These keyboards work in Word, WordPad and other programs.  When I switch to the Russian keyboard layout and type in Notepad++ I get an extended Latin keyboard layout.  I can not figure out why this happens.  I have confirmed this behavior on WinXP Pro SP2, and Win2K SP4 with the identical results.  Even rebooted both systems. 

    What am I missing?

    Vladimir D.

     
    • Paulius
      Paulius
      2005-08-16

      You have two options:
      If you can - use Unicode:
      use unicode ("Format"->"Encode in UTF-8", "Format"->"Encode in UCS-2 Big Endian", "Format"->"Encode in UCS-2 Little Endian" or "Format"->"UTF-8 without BOM").

      If you can not use unicode:
      This is your windows configuration problem actualy. You have to set your (Cyrillic) language for non-Unicode programs. I don't have access to Win2000 nor WinXP at this moment, but if i my memory doesn't lie to me - you can do it in "Control Panel"->"Regional Settings & Languages" (or something like that).

      I am from Lithuania and we have some non-latin characters as well, by changing setting mentioned above - i can see all lithuanian characters in ANSI encoded files.

      Good luck.

       
    • Yes, I did that exactly from Control Panel > Regional Options > Input Locales and then selected the Russian Keyboard.  This works in other applications such as Word, but I can not seem to get this to work in Notepad++.   I still can not figure out what I am missing.  I do not see a way to use the Format > Encode in UTF-8 in Windows. 

      Appreciate the reply.

      Vladimir D.

       
    • Got this to work with your suggestion, though it took me longer than it should have.  Sleep deprivation has a way of doing this. 

      Thanks for your input.

      Vladimir D.