Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

How to change line spacing (not the font) ?

2. Help
thoazu
2009-05-31
2012-11-13
  • thoazu
    thoazu
    2009-05-31

    As I learned I can change the editor text font
    through the menu:

    Settings->Styler configuration->Default style

    to a different font like "Lucida console".

    Fine. However this setup changes ONLY the font style and font size but NOT the line spacing (=gap between two lines).

    Currently the gap between two lines is almost as much as a "normal" line. In other editors where I use the same font "Lucida console" the line spacing is much less.
    So line spacing IS NOT a property of the used font.

    How can I change the line spacing in NP++?

    Thomas

     
    • cchris
      cchris
      2009-06-02

      The ascent and descent are the properties of a given font, so changing the font face may lead to different visual effects.

      If you consider that the same font gives results in Notepad++ that are less satisfactory than in some other editors, then you should report this to the Scintilla project, because it is the Scintilla component which displays the text, Notepad++ doesn't interfere. I cannot think of a Scintilla setting to be tweaked in this respect.

      CChris

       
      • thoazu
        thoazu
        2009-06-20

        >If you consider that the same font gives results in
        >Notepad++ that are less satisfactory than in some other
        >editors, then you should report this to the Scintilla
        >project, because it is the Scintilla component which
        >displays the text, Notepad++ doesn't interfere. I cannot
        >think of a Scintilla setting to be tweaked in this
        >respect.

        This is NOT true!!

        Have a look at the following snapshot:

        http://www.picamatic.com/show/2009/06/20/06/23/4063667_1249x905.png

        (Click on the picture again if it is shrinked displayed)

        Here is the same textfile displayed with the same font (Lucida Console bold 8) by two different editors (Notepad2 and Notepad++) which are BOTH BASED on Scintilla!!

        As you can see there are still some significant line spacing differences!

        So it cannot be an error of Scintalla engine. I guess Notepad++ should provide an appropriate option for that.

        Thomas

         
    • Harry
      Harry
      2009-06-20

      In case of doubt: use the Global override for both font face and size. You probably have the pointsize of the match brace highlight at the default 12 instead of 10.

      This setting applies to all stylers, so not only .txt is affected.

       
      • thoazu
        thoazu
        2009-06-24

        Bingo!!! This was the magic trick.
        Thank you.

        This is somehow weired. How should the common user know this
        side effect?

        I urgently suggest to implement a simultaneous modify of default font size for "Default Style" and "Brace highlight style".

        Thomas

         
    • cchris
      cchris
      2009-06-22

      Perhaps try a different combination of font size and zooming. Zooming increases all dimensions across the board. Font sie usually leaves ascent and descent alone.

      CChris

       
    • cchris
      cchris
      2009-05-31

      A line may be using plenty of fonts depending on the highlighting scheme selected. The spacing is normal, but the interline spacing is based on the tallest font you might be using for this language in this theme.

      I'm sure you'll find an unexpectedly tall font by reviewing your settings. Decreasing its size will decrease the line spacing.

      I think this was asked before on this forum.

      CChris

       
      • thoazu
        thoazu
        2009-06-01

        >A line may be using plenty of fonts depending on the >highlighting scheme selected. The spacing is normal, but the >interline spacing is based on the tallest font you might be >using for this language in this theme.
        >
        >I'm sure you'll find an unexpectedly tall font by reviewing >your settings. Decreasing its size will decrease the line >spacing.

        Hmm, I am NOT using a highlight schema. I am using the "Feault Style" for a simple *.txt file.

        So there are no different font embedded/used. Only one!
        See this snapshot:

        http://www.picamatic.com/show/2009/06/01/01/30/3848376_1093x724.png

        So the "tallest" font as the only font used.
        So again: how can I decrease the line spacing?

        Thomas

         
      • thoazu
        thoazu
        2009-06-01

        >A line may be using plenty of fonts depending on the >highlighting scheme selected. The spacing is normal, but the >interline spacing is based on the tallest font you might be >using for this language in this theme.
        >
        >I'm sure you'll find an unexpectedly tall font by reviewing >your settings. Decreasing its size will decrease the line >spacing.

        Hmm, I am NOT using a highlight schema. I am using the "Feault Style" for a simple *.txt file.

        So there are no different font embedded/used. Only one!
        See this snapshot:

        http://www.picamatic.com/show/2009/06/01/01/30/3848376_1093x724.png

        So the "tallest" font as the only font used.
        So again: how can I decrease the line spacing?

        Thomas