TAB's

2011-11-12
2014-06-25
  • Uffe Kousgaard
    Uffe Kousgaard
    2011-11-12

    How do I avoid TAB's in my files, when I am using auto-indent? I want spaces instead.

     
  • cchris
    cchris
    2011-11-13

    Settings -> Preferences -> Language/TAB settings. You should locate the relevant checkbox easily then…

    CChris

     
  • Ron Jensen
    Ron Jensen
    2014-06-24

    So, I'm using NPP to prepare a file for pasting into Excel. That means I need exactly the number of tabs I type, no more, no less. Today I'm trying to use a few spaces followed by a tab so I can line my columns up if the first entry is blank. NPP insists on converting those first spaces to a tab instead of spaces. I don't see a relevant option for turning this misguided feature off.

    Is there a way?

    Thanks

     
  • Thomas
    Thomas
    2014-06-25

    Moin, moin,

    In the attached screen shot you can see, where to disable conversion of TABs into space character generally.

    I just tested with version 6.6.6 and you are right: when typing space characters in the beginning of a line and then pressing TAB the space characters are removed. I would think that this behavior is more a feature than a bug (less amount of characters to store).

    The only workaround to this behavior is to enter a single character in the beginning of a line. When typing space and TAB characters in a sequence the space characters are not merged into the TABs (because of the character in the 1 column). Of course you must finally delete the leading dummy character (either in Notepad++ using the column mode or in Excel by deleting the first column).

    Regards,
    Thomas