Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Explorer context menu entry doesn't work

2. Help
2006-03-07
2012-11-13
  • I have installed Notepad++ v3.5 (executable) on Windows XP SP2. After the installation was finished I have found out that the Explorer context menu entry (right click) doesn't work.

    I have tried to run the following command: 'regsvr32 nppshellext.dll' from the installation folder and I got an error message: Load library ("nppshellext") failed.

    Any solution?

     
    • Paulius
      Paulius
      2006-03-07

      Sounds like your missing some runtimes..
      First check if you have msvcr71.dll and msvcp71.dll in your <windows>/system32 directory - if not, google for them (they are made by microsoft and they are freely distributable). If you have them and the extension still doesn't load, then you could use "dependency walker" (from http://dependencywalker.com/\) to check & google for other deps.

       
    • Thanks for the help, I found out the I have msvcr71d.dll and msvcp71d.dll. Isn't this the same?

       
      • No, they are not the same. The "d" stands for debug. Debug versions are not freely redistributable - they're ment for debuging/testing your applications.

        Tu use the shell extension, you must have release versions of these files (as mentioned above).

         
    • Hi,
      I also have a problem with Notepad++ ver 3.5.
      Operating system is WinXP SP2, and I have a dll's mentioned above, but can't make it work.
      It's work fine on ver 3.4, but on WinXP SP1a.
      Then switched to SP2 & ver 3.5 -> problem.
      I'm trying to figured out is the problem with SP2 or Notepad++.
      Sorry for my poor English.
      Best regards.
      Almir.

       
    • When I download msvcr71.dll and msvcp71.dll to system32 folder, I can regsvr32 nppshellext.dll successfully and then the "Open the Notepad++" funtion is appear in my context menu.

       
    • I already have a needed dll's, but I don't properly run regsvr32.
      If you have a dll's mentioned in post above, then you should run "regsvr32 nppshellext.dll" in Notepad++ directory and it should work now.
      It's work for me.