Notepad++ defaulting syntax highlighting to CoffeeScript for .cpp files

2013-10-11
2014-04-14
  • lotuspirate
    lotuspirate
    2013-10-11

    I am new here and I don't know if this is the right place to post this or if it is a bug that requires a ticket (I am guessing it is but it might be something I have done wrong since I haven't found anything similar with google).

    I just installed Notepad++ 6.5 today over my previous installation of Notepad++ 5.9.3. Whenever I open a .cpp file, Notepad++ 6.5 seems to be detecting the file as a CoffeeScript file and defaulting to CoffeeScript syntax highlighting rather than C++. Even when I removed CoffeeScript from the Language Menu it seems to default to it anyway. It is inconvenient to change it to C++ every time. Is there any way to fix this?

    edit: It is also occurring for .txt files.

     
    Last edit: lotuspirate 2013-10-12
  • jmwelch
    jmwelch
    2013-10-31

    It's been a little while - did you ever get this figured out?

    It sounds like there may be a setting from your old installation that's sticking around and causing problems. If you're still having problems, take a look at stylers.xml and langs.xml in %APPDATA%\Notepad++, and search for cpp. Make sure it's not listed as an extension for anything but C++ files.

     
  • Noel
    Noel
    2013-11-05

    I am having exactly the same problem: recently updated to version 6.5 from an older version

    Now, whenever I load a file of any extension (most commonly PHP) it shows up with some other language styling. I don't know which language it is, but it certainly isn't PHP. So each time I have to go and manually change it . A real pain.

    This is true for any type of extension, eg css etc.

    It used to work fine - it would automatically do the styling to match the extension.

    I have been through all the settings I can find, but to no avail. I looked at stylers.xml and lang.xml and they seem fine.

    Any other suggestions?

    Thanks

    Noel

     
  • Etdashou
    Etdashou
    2013-11-13

    Hi,

    I have the same bug since I updated to 6.5.
    I have verified the langs.xml and stylers.xml file. I have searched in it and this is what I have:
    Language name="php" ext="php php3 phtml" commentLine="//" commentStart="/" commentEnd="/">
    LexerType name="php" desc="php" ext="">

    Language name="coffeescript" ext="litcoffee" commentLine="#" commentStart="" commentEnd="">
    LexerType name="coffeescript" desc="CoffeeScript" ext="">

    I really don't know if I need to check something else but doing a CTRL+F with php this is all I found.

    I have started a fresh installation of a the Portable version of Notepad++. 6.5.1 ZIP version.

    Any help would be appreciated.

     
  • Etdashou
    Etdashou
    2013-11-13

    Ok,

    I have done some tests. I have tried the Zip package of 6.5.1, 6.5 and 6.4.5. Each time I was completly deleting the previous installation.

    With 6.4.5, everything is OK. I open .php files and the language is correctly selected.

    With 6.5 and 6.5.1, CoffeeScript is selected for php files.

    I have no idea why - but I hope I helped. I will use 6.4.5 for the time being.

    thanks

     
  • Gerben Jacobs
    Gerben Jacobs
    2014-01-31

    I'm having this problem as well. This appears to be a serious issue, so that's why I'm bumping this topic.

     
  • Does this happen with all PHP files? I can't reproduce it.

     
  • Fab313
    Fab313
    2014-02-26

    I have the same problem.
    I'm using v6.5.2, and every time I open a file (any kind of file), it's detected as a CoffeeScript file.
    I have to manually change the language through the language menu in order to have to correct syntax highlighting.
    And When I go in settings > style configurator, "CoffeeScript" is the last language in the language list...

     
  • cchris
    cchris
    2014-03-02

    I am suspecting that the problem takes place when installing over older versions of N++. Can you reproduce the issue if installing in a new folder?

    CChris

     
  • Same problem: .txt files are by default marked as CoffeeScript.
    Just installed version 6.5.5 over my previous installation, where this did not happen.
    ...
    Ok, I found the problem or at least the trigger for it: the behaviour only occurs when checking 'use as default html viewer' during installation/upgrade!

    I just uninstalled the new version (where I had activated above option for the first time) and installed the old (6.5.4) back again. During install I checked the option and voila, the problem also occurred.

    Can anyone also reproduce this?